2.5 to 4.0 Throttle body swap. Help!! - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-07-2013, 08:57 PM   #31
Jeeper
 
jonothehut's Avatar
 
Join Date: Feb 2013
Location: South Carolina
Posts: 33
Quote:
Originally Posted by CarolinaBound
All this work for ~1 extra HP.
Hasn't been too much work. Just unbolting and bolting everything back on a couple times.
It's a tough life for us 4banger owners.

jonothehut is offline   Quote Quick Reply
Old 03-07-2013, 08:59 PM   #32
Jeeper
 
jonothehut's Avatar
 
Join Date: Feb 2013
Location: South Carolina
Posts: 33
Quote:
Originally Posted by Sandstorm95
i had the same issue but its because i didnt swap out the iac. if u compare the 4.0 one to he 2.5 there is a huge difference. The 2.5 one also says "2.5" on it to help a little
I think I know exactly what your talking about. I'm going to try it out this weekend.

jonothehut is offline   Quote Quick Reply
Old 03-11-2013, 11:48 AM   #33
Jeeper
 
jonothehut's Avatar
 
Join Date: Feb 2013
Location: South Carolina
Posts: 33
Quote:
Originally Posted by Sandstorm95 View Post
i had the same issue but its because i didnt swap out the iac. if u compare the 4.0 one to he 2.5 there is a huge difference. The 2.5 one also says "2.5" on it to help a little
Sandstorm95, that totally worked. Swapped out the iac, reset the ECM, started right up with no issue. I can't believe I missed that. Thanks man.

When I do start it up it does sit around 2000rpm then slowly works its way down to around 1000rpm. Doesn't seem to be any issues though.

Sorry for the 3rd post in a row. I can't find how to edit a post.
jonothehut is offline   Quote Quick Reply
Old 03-11-2013, 02:41 PM   #34
Jeeper
 
Gunz n tractorz's Avatar
 
Join Date: Apr 2012
Location: Rising sun md
Posts: 1,063
Quote:
Originally Posted by jonothehut

Hasn't been too much work. Just unbolting and bolting everything back on a couple times.
It's a tough life for us 4banger owners.
Agreed
Gunz n tractorz is offline   Quote Quick Reply
Old 03-11-2013, 02:43 PM   #35
Jeeper
 
Gunz n tractorz's Avatar
 
Join Date: Apr 2012
Location: Rising sun md
Posts: 1,063
Quote:
Originally Posted by jonothehut

Sandstorm95, that totally worked. Swapped out the iac, reset the ECM, started right up with no issue. I can't believe I missed that. Thanks man.

When I do start it up it does sit around 2000rpm then slowly works its way down to around 1000rpm. Doesn't seem to be any issues though.

Sorry for the 3rd post in a row. I can't find how to edit a post.
What's the iac?
Gunz n tractorz is offline   Quote Quick Reply
Old 03-12-2013, 08:14 AM   #36
Jeeper
 
ThePhantomPatriot's Avatar
 
Join Date: Jul 2012
Location: Delta, PA
Posts: 259
I swapped mine this past weekend, but haven't had a chance to see how she runs. I was working on the exhaust and the pipes were so rusted I couldn't get them off, and of course I had already grinded the exhaust pipe in half so it was just a header and no down pipe. Needless to say I had to get it towed and don't have it back yet. Getting shop to do the headers while they're at it.

Also when I did it I figured out why my engine was whistling, the original gasket on the TB was completely gone so air was getting in the space b/e that and the intake manifold.
__________________
1995 - 2.5L Low Output Wrongler
ThePhantomPatriot is offline   Quote Quick Reply
Old 03-13-2013, 04:02 PM   #37
Jeeper
 
ThePhantomPatriot's Avatar
 
Join Date: Jul 2012
Location: Delta, PA
Posts: 259
Just got my YJ back from the shop, sound beautiful now, she purrs when on the throttle and is quiet when idling, no longer sounds like a boat. My exhaust header was leaking since the Jeep factory didn't put a gasket between it and the block. And I had a radial fracture at the flange of the down pipe which went over 180^ around and had a good half inch gap.

Since I can drive it again the engine starts at 2500rpm and is idling at 1500-1700rpms and when I shift I have to ease into gear and then get on the gas because it is idling too high. Also when I barely have my foot touching the peddle it is very touchy and will jump 500-1000rpms with very little pressure. I swapped out the sensors too, but not the IAC housing, was that supposed to be swapped too?

Questions:
1- Do I have to adjust the idle, or will the computer relearn the proper setting for the correct idle?
2- Once the engine learns the new setting will it have to relearn when I unplug the battery to do work and then plug it in once I'm done (resetting computer)?

Thanks.
__________________
1995 - 2.5L Low Output Wrongler
ThePhantomPatriot is offline   Quote Quick Reply
Old 03-13-2013, 04:37 PM   #38
Jeeper
 
AZ_Zoner's Avatar
 
Join Date: May 2012
Location: Valley of the Sun, Gilbert, AZ
Posts: 247
Images: 3
Quote:
Originally Posted by Gunz n tractorz View Post
What's the iac?
Idle Air Control valve. Looks like this.

cb
Attached Thumbnails
Click image for larger version

Name:	IAC%20rs.jpg
Views:	33
Size:	104.8 KB
ID:	222227  
AZ_Zoner is offline   Quote Quick Reply
Old 03-13-2013, 06:14 PM   #39
Jeeper
 
jonothehut's Avatar
 
Join Date: Feb 2013
Location: South Carolina
Posts: 33
Quote:
Originally Posted by Gunz n tractorz View Post
What's the iac?
Quote:
Originally Posted by AZ_Zoner View Post
Idle Air Control valve. Looks like this.

cb

EXACTLY! Took me a while and tons to searching to figure I had to swap that out too.
This thread helped me out a lot. But I didn't have a MAP sensor. Not sure if yours does.
Cleaning IAC and Throttle body write up (for dummies) - JeepForum.com

EDIT: ActuallySandstorm95's post is what ultimately lead to me figuring it out
jonothehut is offline   Quote Quick Reply
Old 03-17-2013, 02:01 PM   #40
Jeeper
 
Sandstorm95's Avatar
 
Join Date: Mar 2012
Location: Long Island
Posts: 182
Quote:
Originally Posted by jonothehut View Post

Sandstorm95, that totally worked. Swapped out the iac, reset the ECM, started right up with no issue. I can't believe I missed that. Thanks man.

When I do start it up it does sit around 2000rpm then slowly works its way down to around 1000rpm. Doesn't seem to be any issues though.

Sorry for the 3rd post in a row. I can't find how to edit a post.
Glad it worked ! It took me punching in my center console before I realized I didn't swap it out lol
Sandstorm95 is offline   Quote Quick Reply
Old 03-17-2013, 02:26 PM   #41
Jeeper
 
Join Date: Feb 2013
Location: Idabel, Ok
Posts: 76
As said in prior post you do have to swap the sensors but as far as the iac you have to use the 2.5l the housing for it as well. Haven't done the 19lb injectors but want to.
Dac7529 is offline   Quote Quick Reply
Old 03-23-2013, 11:28 AM   #42
Jeeper
 
jonothehut's Avatar
 
Join Date: Feb 2013
Location: South Carolina
Posts: 33
Quote:
Originally Posted by Sandstorm95 View Post

Glad it worked ! It took me punching in my center console before I realized I didn't swap it out lol
I was about at that point. Instead I slapped myself in the head for missing the iac housing.

jonothehut is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Body Lift rspangler0306 JK General Discussion Forum 27 04-23-2014 08:20 PM
Getting ready to regear to 4.10's. Braveheart12JK JK General Discussion Forum 60 05-07-2012 12:46 PM
Benefits to an electric cooling fan? denisbaldwin General Jeep Discussion 11 03-26-2012 07:24 PM
New Member Just Moved To Greenville NC SteelGold WF New Member Check In 12 03-18-2012 02:20 PM
I want to clean my intake manifold. wherewasi YJ Tech Forum 3 03-15-2012 01:58 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:09 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC