4.0l broken pass. mount - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-03-2009, 06:57 PM   #1
Jeeper
 
Join Date: Jan 2009
Location: scranton, pennsyltucky
Posts: 43
4.0l broken pass. mount

Like the title says I was wondering if this is a common problem or not? I am actually in the market to pick up an xj to swap a 6 cylinder into my 2.5 wrangler. Since I've been looking for a cheap xj everyone of them the motor mount is broken on the passenger side. Where the cast bracket mounts to the motor the bolts all seem to snap off. Is this a easy fix or would it be better to just scrap the truck is in. By easy I mean welding a nut to the broken stud or drilling it out and retapping the hole. Would the problem be solved by upgrading the grade of the bolts? Thanks in advance any help would be grately appreciated.

jeepster213 is offline   Quote Quick Reply
Old 03-03-2009, 09:12 PM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
it shouldn't be hard to extract those bolts if the bolts broke off. they all do that cuz the motor mounts go bad, but no one ever replaces them, and then the bolts break.

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-05-2009, 06:55 AM   #3
Jeeper
 
Join Date: Jan 2009
Location: scranton, pennsyltucky
Posts: 43
From what I seen the rubber mount is good but the bolts broke off in the block. Would I be able to just upgrade to a grade 8 and eliminate the problem?
jeepster213 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to mount CB? Darton Communications and Electronics 55 05-25-2009 07:06 PM
intresting info on the 4.0L TB swap... foxinthemudd General Jeep Discussion 10 03-10-2008 11:37 PM
New Ram Mount for the Footman Loop hutchman Communications and Electronics 6 09-03-2007 01:06 AM
hi-lift mount 94redwrangler YJ General Discussion Forum 8 01-03-2007 06:12 AM
Lunchbox Lockers and broken axles? U.S.MarineLJ TJ General Discussion Forum 14 03-12-2006 01:21 PM



» Featured Product

All times are GMT -5. The time now is 08:25 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC