4.2 acceleration problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-01-2012, 12:35 PM   #1
Jeeper
 
Join Date: Apr 2012
Posts: 15
Unhappy 4.2 acceleration problem

I have a 1990 jeep wrangler 4.2 Automatic I-6 with a 34 DGEC Weber carb fuel pressure reg at 3.5 Electric fan and nuttered
usually when the jeep is warmed up and im going down the road and come to a hill or even sometimes leaving a red light i get this poor acceleration problem and it wont bog out and die but it will bog down and finally catch back up the other day i went to go up a hill on the road and literally had the petal to the floor to get up the hill and it wasnt that big of a hill at all

Please help I have no idea why its doing this

roostersansone is offline   Quote Quick Reply
Old 04-01-2012, 02:05 PM   #2
Jeeper
 
Beachcruiser's Avatar
 
Join Date: Feb 2012
Location: Raleigh, NC
Posts: 429
Could be several things.

1) make sure your ignition timing is what it's supposed to be. About 8 degrees at idle & 34 total. You'll need a timing light. There are several good write up on the net if you just google ''setting ignition timing".

2) Check the float level in carb. I'm not sure what it's supposed to be, but you can find that info pretty easily too.

3) Check accelerator pump function on the carb, too.

4) Your transmission is supposed to kick down into the next lowest gear when you floor the gas pedal or come to a stop....doesn't sound like your is doing this. Most are cable or rod activated off the carb/throttle linkage. Sorry, but I'm not familair w/ jeep auto transmissions, but I'm sure somebody here is. You might want to search "kickdown" on this forum.

I'd probably check #4 first.....if the transmission isn't kicking down, then the other things could be fine & it would still have problems. Could be as simple as the rod/cable came off, or it's low on fluid.

Good Luck!

Beachcruiser is offline   Quote Quick Reply
Old 04-01-2012, 06:20 PM   #3
Jeeper
 
90YJinPC's Avatar
 
Join Date: Feb 2010
Location: Panama City, Fl
Posts: 132
Quote:
Originally Posted by Beachcruiser View Post
Could be several things.

1) make sure your ignition timing is what it's supposed to be. About 8 degrees at idle & 34 total. You'll need a timing light. There are several good write up on the net if you just google ''setting ignition timing".

2) Check the float level in carb. I'm not sure what it's supposed to be, but you can find that info pretty easily too.

3) Check accelerator pump function on the carb, too.

4) Your transmission is supposed to kick down into the next lowest gear when you floor the gas pedal or come to a stop....doesn't sound like your is doing this. Most are cable or rod activated off the carb/throttle linkage. Sorry, but I'm not familair w/ jeep auto transmissions, but I'm sure somebody here is. You might want to search "kickdown" on this forum.

I'd probably check #4 first.....if the transmission isn't kicking down, then the other things could be fine & it would still have problems. Could be as simple as the rod/cable came off, or it's low on fluid.

Good Luck!
I would also start with #4, mine would come loose @ the transmission. Ended up installing a clip to keep it on.
90YJinPC is offline   Quote Quick Reply
Old 04-02-2012, 10:25 AM   #4
Jeeper
 
Join Date: Apr 2012
Posts: 15
Thanks Great write up makes perfect since ill try it. I went out there and looked at the cable that is connected to my throttle body and when pull down on the throttle body the cable gets shorter idk if this is what is suppose to do i counldnt find a forum on it but i tried youtube and every one of them pulled tighter. Its a Brand new Carb not even 2 weeks old but see i wasnt the one who installed it so i dont know how the cable originally went.
If yall have a pic of the throttle body that would help me a bunch cant find it anywhere thnxs
roostersansone is offline   Quote Quick Reply
Old 04-02-2012, 09:50 PM   #5
Jeeper
 
Join Date: Apr 2012
Posts: 15
AH ok so doing some research on this kickdown rod that i have i found out that mine is missing this spring that connects it or shall i say retracts it back toward the throttle body, im thinking that might be the issue im having
roostersansone is offline   Quote Quick Reply
Old 04-03-2012, 06:27 PM   #6
Jeeper
 
Join Date: Apr 2012
Posts: 15
Nope i replaced the spring and still no good idk what it wrong i also went ahead and did the team rush to it still no difference i guess im left with the timing being off possibly but I doubt it
roostersansone is offline   Quote Quick Reply
Old 04-03-2012, 07:15 PM   #7
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,006
Send a message via Yahoo to Nubby55
Just because the kick down is connected, does not mean it's adjusted, try to find out how to adjust it.
Nubby55 is online now   Quote Quick Reply
Old 04-03-2012, 10:01 PM   #8
Jeeper
 
Beachcruiser's Avatar
 
Join Date: Feb 2012
Location: Raleigh, NC
Posts: 429
Nubby's right. You can get an idea by looking at the trans hookup end & seeing how far the lever is supposed to move. If the kick down rod doesn't move it by 3/4 throttle, it needs to be adjusted.

If your trans isn't shifting into the proper gear for throttle input....it's gonna be a dog.
Beachcruiser is offline   Quote Quick Reply
Old 04-04-2012, 01:14 PM   #9
Jeeper
 
Join Date: Apr 2012
Posts: 15
Found out kickdown rod is fine im not getting enough gas when the carb kicks in the secondaries they are wanting more gas and not getting it

Anyone know what to do about this?
roostersansone is offline   Quote Quick Reply
Old 04-04-2012, 09:44 PM   #10
Jeeper
 
Join Date: Feb 2012
Posts: 52
Quote:
Originally Posted by roostersansone
Found out kickdown rod is fine im not getting enough gas when the carb kicks in the secondaries they are wanting more gas and not getting it

Anyone know what to do about this?
Maybe something to do with your fuel regulator.. Mine doesn't have one and i don't have your problem. I have an otherwise identical set up
tyler1234567 is offline   Quote Quick Reply
Old 04-04-2012, 09:47 PM   #11
Jeeper
 
busemans's Avatar
 
Join Date: Dec 2010
Location: on the gulf of mexico
Posts: 1,352
you have a clog somewhere.


i had that carb. you are better off with a one barrel or the stock carb then that carb. when my holley needed work, i put that 34 back on during the repairs. what a piece of crap. i will never run that carb on anything again. get a 32/26 or get a 38 but get rid of that non-weber
__________________
A lot of teenagers are people who express a burning desire to be different be dressing exactly alike.
Panties aren't my favorite, but they're right next to it...
No one is normal, there are just a lot of weird people with things in common.
busemans is offline   Quote Quick Reply
Old 04-05-2012, 11:18 AM   #12
Jeeper
 
Join Date: Apr 2012
Posts: 15
Anyone have a opinion about the mc carb?
roostersansone is offline   Quote Quick Reply
Old 04-05-2012, 12:01 PM   #13
Jeeper
 
Beachcruiser's Avatar
 
Join Date: Feb 2012
Location: Raleigh, NC
Posts: 429
Quote:
Originally Posted by roostersansone View Post
Anyone have a opinion about the mc carb?
Yep, they are fantastic if you get the right application for your jeep.

I found one for 25 bucks on Clist & rebuilt it.....made a HUGE difference, especially for about 90 bucks total! Mine is off a 71 302 mustang.

It now starts 1st turn of the key anytime, hot or cold.......idles smoothly at 650rpms, gets better mileage and makes way more usable power than the stock carb.

That & the ignition mods from the 'team rush' write up made it run like a totally different motor.
Beachcruiser is offline   Quote Quick Reply
Old 04-05-2012, 12:37 PM   #14
Jeeper
 
MellowYellow89YJ's Avatar
 
Join Date: Feb 2011
Location: NE Florida
Posts: 507
The MC 2150 is a great carb. Easier to tune, and more reliable than the weber.
__________________
A few FACTS:
Rectangle headlights ARE kinda cool.
YJ does NOT stand for "Yuppie Jeep".
Jeeps should only have TWO doors.
You should ALWAYS wave at other JEEP drivers.
MellowYellow89YJ is offline   Quote Quick Reply
Old 04-05-2012, 09:01 PM   #15
Jeeper
 
busemans's Avatar
 
Join Date: Dec 2010
Location: on the gulf of mexico
Posts: 1,352
preach on brothers, preach on.

i am in agreement, i like the mc2100 i have

__________________
A lot of teenagers are people who express a burning desire to be different be dressing exactly alike.
Panties aren't my favorite, but they're right next to it...
No one is normal, there are just a lot of weird people with things in common.
busemans is offline   Quote Quick Reply
Reply

Tags
4.2 , acceleration problems , bogging down , nutter bypass , weber

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another problem that needs diagnosed fourty4magjr TJ General Discussion Forum 29 04-24-2012 12:29 PM
1997 TJ - sputtering problem and volt surge Sktownsend TJ General Discussion Forum 19 04-16-2012 06:12 AM
i need a 4.2 harmonic balancer for v belts csb41502 Classifieds Archive 1 04-01-2012 04:25 PM
transmission problem! I NEED HELP!! pauls94 YJ Tech Forum 2 04-01-2012 10:58 AM
Idle problem man71892 General Jeep Discussion 2 03-31-2012 09:40 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC