4.2 random cut offs - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-20-2012, 08:49 PM   #1
Jeeper
 
wig-wag's Avatar
 
Join Date: Feb 2012
Location: NC
Posts: 171
Images: 2
4.2 random cut offs

I have a 90 YJ with a 4.2 and a Weber carb (32/36); it runs great until it decides it doesn't want to anymore, then it just cuts off. It sometimes backfires and gives a strong fume smell and sometimes it just cuts off. It always cranks back up after I let it sit for a minute. sometimes it goes for days without cutting off (but never more than a few days) and sometimes it does it 2 or 3 times a day (usually when it cuts off once, it does it several times in a row). Does it when it's hot, cold, wet or dry, doesn't matter.


I replaced the coil (it was looking pretty bad), cleaned out the carb, put a new fuel filter on it and checked all the fuel lines.

I've read a lot on here and think it may be one of two things: 1. my Ignition Control Module or 2. my distributor.

Just bought the YJ a couple months back, looks like it has new wires and plugs and distributor cap (don't know if the actual distributor was replaced).

If anyone has any ideas please let me know.

Thanks

wig-wag is offline   Quote Quick Reply
Old 03-21-2012, 06:01 AM   #2
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,641
Images: 1
Replace the Ignition Control Module.

kik is online now   Quote Quick Reply
Old 03-21-2012, 09:19 AM   #3
Jeeper
 
Planetisfull's Avatar
 
Join Date: Feb 2011
Location: North central pa
Posts: 59
Quote:
Originally Posted by kik
Replace the Ignition Control Module.
This
Planetisfull is offline   Quote Quick Reply
Old 03-22-2012, 09:17 AM   #4
Jeeper
 
wig-wag's Avatar
 
Join Date: Feb 2012
Location: NC
Posts: 171
Images: 2
Thanks guys! That's what I was leaning towards. Autozone said they could test it, so I may do that. I'll update this thread with the results.
wig-wag is offline   Quote Quick Reply
Old 03-22-2012, 10:27 PM   #5
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,043
Send a message via Yahoo to Nubby55
Quote:
Originally Posted by kik View Post
replace the ignition control module.

x2
Nubby55 is offline   Quote Quick Reply
Old 04-01-2012, 06:09 PM   #6
Jeeper
 
wig-wag's Avatar
 
Join Date: Feb 2012
Location: NC
Posts: 171
Images: 2
Finally got an ICM today. Probably gonna put that on tomorrow. I'll keep you all posted. Thanks!
wig-wag is offline   Quote Quick Reply
Old 04-23-2012, 09:20 PM   #7
Jeeper
 
wig-wag's Avatar
 
Join Date: Feb 2012
Location: NC
Posts: 171
Images: 2
The ICM worked on mine; hasn't cut off since I put it on (knock on wood)
wig-wag is offline   Quote Quick Reply
Old 04-24-2012, 04:29 AM   #8
Newb
 
quikfix's Avatar
 
Join Date: Apr 2012
Location: St Lucia west Indies
Posts: 8
Hi did this slove your problem am having the same similuar problem but my plugs get very black and it backfires no idle too

quikfix is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random Photo Thread Mr Mac Pictures Forum 182 10-14-2012 08:59 AM
cut flares TJDrillSergeant TJ General Discussion Forum 2 04-09-2012 04:45 PM
4.2 swap to 4.0 red-jeep YJ Tech Forum 20 04-01-2012 08:23 PM
90 Wrangler 4.2 vacuum line troubles jslayton2 YJ Tech Forum 0 03-18-2012 09:22 PM
Colder Spark Plugs for 4.2 kryptik YJ Tech Forum 5 03-16-2012 07:34 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:05 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC