4.2L running like crap, what am I missing? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-06-2009, 11:41 AM   #1
Jeeper
 
Join Date: Apr 2009
Posts: 62
4.2L running like crap, what am I missing?

Hey gang

Started my 1987 4.2L today and it's not running well. It's idling around 1000 rpm, it won't shut off without severely running on, and it bogs when revved in neutral. I set the timing as per the sticker, "9 degrees BTDC @ 1625 rpm. I'm assuming this is with the vaccuum line attached?

I'm guessing the issues are with the vaccuum lines that I have been trying to straighten out. I have an intact diagram on the hood and in the manual, as well as access to another 1987 YJ which the owner claims to be unmolested, engine-wise.

Heck, if anything, it ran better when it was warming up.

Any ideas what I'm missing?

Jake

Covrace is offline   Quote Quick Reply
Old 05-06-2009, 01:45 PM   #2
Jeeper
 
scrambler1's Avatar
 
Join Date: Jan 2008
Location: vermont
Posts: 486
Could many things ignition (plugs wires rotor stator ign. box)
Fuel filter, Vacuum leak.
First re set the timing with the vacuum advance DISCONNECTED then take your time and diagnose. Could be your carb needs to be rebuilt.
Good luck let us know.
PS - by a manual it will be your best friend.

__________________
94' wrangler 4 cyl. 5 speed D30/8.8 ARB
82' scrambler 350 TBI/700r4 D30/Currie 9"
07' JK sahara
Whats the deal with the facebook crap?? ->->->->
Grown men should NOT be on Facebook.
scrambler1 is offline   Quote Quick Reply
Old 05-06-2009, 05:07 PM   #3
Jeeper
 
Join Date: Apr 2009
Posts: 62
thanks guys, I didn't disconnect and plug the advance line. Retimed and it runs fine. I have a chilton manual and it's pretty good. Wish Bentley made a YJ-exclusive manual.
Covrace is offline   Quote Quick Reply
Old 05-06-2009, 05:14 PM   #4
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
ya, sounded like timing wasn't right, timing is basically alwasy set with vacuum advance plugged.

glad its fixed up. haynes makes an ok yj manual.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Am I missing a fan? k7svv JK General Discussion Forum 4 04-02-2009 05:09 AM
Who's running 10" rims instead of 8"? cavediverjc TJ General Discussion Forum 10 07-14-2007 02:36 AM
YJ with bad idle and rough running erickpl YJ Tech Forum 3 06-22-2007 08:24 AM
running a marathon for the leukemia and lymphoma society save_alkaline Off-Topic 4 02-10-2007 10:26 AM
running temp of 4.2l jeepercreeper77 YJ Tech Forum 1 12-13-2006 11:04 AM



» Featured Product

All times are GMT -5. The time now is 12:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC