4 wheel drive light on. No 4wd - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-26-2012, 06:30 PM   #1
Newb
 
Join Date: Jul 2012
Location: Dacula Georgia
Posts: 12
Exclamation 4 wheel drive light on. No 4wd

So basically, i can shift my 4wd lever down to 4hi, and the light comes on. i can also drop it down to 4low and i can feel it in low gear. i went under and the front drive shaft locks and wont spin (by hand) when i shift in 4wd. However in the mud only my back two tires spin. i ran a test and put it "4wdhi" and jacked one front tire off the ground and the tire spun freely..i think it should be locked someone help me please, just got new tires and i want to break them in!

It is a 4cyl 94 wrangler

KevinWhiteYJ is offline   Quote Quick Reply
Old 07-26-2012, 07:26 PM   #2
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 9,796
Images: 5
sounds like a vacume disconnect issues. Check the connections over the passengerside axle area. There are some wires etc to check. worst case you can pin in place the shift fork that locks the two axle shafts to gether on that side. We have some links at the top of the YJ page that talk about it or aleast will give you some pic's to see what it looks like.

__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote Quick Reply
Old 07-26-2012, 08:54 PM   #3
Newb
 
Join Date: Jul 2012
Location: Dacula Georgia
Posts: 12
Thanks for the reply. Earlier I removed my diff cover and had a buddy drive while I saw the gears spin in the garage in 4wd?? So if the gears spin inside whats that mean?
Also if that fork wasn't shifting wouldn't that stop the light from comming on?
KevinWhiteYJ is offline   Quote Quick Reply
Old 07-26-2012, 09:25 PM   #4
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 9,796
Images: 5
I would expect them move as there is a shaft to move them, but for 4wd to work correctly the passenger side shaft has to be working, and I think the 4wd light is routed to that system.
__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote Quick Reply
Old 07-27-2012, 08:16 AM   #5
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,341
Images: 1
Your switch on a 94 is electric that operates the 4wd light. On my 89 it's vacuum operated so when there was a vac. problem the switch didn't work because the fork didn't move far enough to activate it. The fork has to move the collar over to lock the axles. When the fork moves over it should trip the switch for the 4wd light. Was the collar that locks the axles in the center connecting both? If the fork isn't moving the collar over to lock the axles then there is possibly a vac. problem or with the axle vacuum switch. On yours I believe the vac. lines come in on the right side and there's an electrical switch on the far left. There is also a vac. switch on the transfer case that can go bad.
kik is offline   Quote Quick Reply
Old 07-27-2012, 11:13 AM   #6
Newb
 
Join Date: Jul 2012
Location: Dacula Georgia
Posts: 12
I got it working! It turns out the collar on the axel was not inline with the fork. So the fork was moving but the collar wasn't moving with it. I lined them together, and then lifted all 4 tires of the ground and they all spun! Thanks y'all for your help!
KevinWhiteYJ is offline   Quote Quick Reply
Old 07-27-2012, 11:58 AM   #7
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,341
Images: 1
Quote:
Originally Posted by KevinWhiteYJ View Post
I got it working! It turns out the collar on the axel was not inline with the fork. So the fork was moving but the collar wasn't moving with it. I lined them together, and then lifted all 4 tires of the ground and they all spun! Thanks y'all for your help!
Great to hear you found the problem.

kik is offline   Quote Quick Reply
Reply

Tags
4wd hi problem , 4wd not engaging , transfer case

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC