4l wrangler snapped guage temp sensor - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-24-2010, 11:23 AM   #1
Jeeper
 
Join Date: Apr 2010
Location: Oxfordshire, UK
Posts: 43
Smile 4l wrangler snapped guage temp sensor

Hi all,
Whilst trying to remove the temperature guage sensor on my 95 4l YJ Wrangler (its the one at the top rear of the engine by the firewall) to remove an airlock, it has snapped flush with the engine, damn rust. Is it best to try to get it out with stud extractors or drill and tap. If drill and tap is the answer what size is the thread as I dont want too big a hole.
Any advise would be appreciated very much
many thanks for looking
Tony

tony01 is offline   Quote Quick Reply
Old 04-24-2010, 07:59 PM   #2
Supporting Member

WF Supporting Member
 
scott howard's Avatar
 
Join Date: Dec 2009
Location: wichita falls texas
Posts: 1,035
soak it with pb blaster for at least over night and try a stud remover . that should do it
__________________
Scott Howard
940-444-1972
scott howard is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
coolant temp sensor whitebuffalo YJ Tech Forum 3 04-24-2010 11:55 AM
2003 2.4 air temp sensor problem fred9981 TJ Tech Forum 0 01-25-2010 08:20 PM
Fellow Ohio Jeepers Help fick15 Ohio Jeep Forum 11 01-19-2010 11:56 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC