4wd indicator light will not come on - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-14-2013, 06:25 PM   #1
RUBISEAN

WF Supporting Member
 
mcseang's Avatar
 
Join Date: Sep 2011
Location: wesley chapel,fl
Posts: 399
4wd indicator light will not come on

4wd indicator will not light up. I have tried grounding the vacuum switch by the battery, disconnecting the vacuum line and sucking into to it, verified vacuum lines are intact and made sure the bulb was good...... whats next? replace the vacuum switch on the firewall, or the switch on the transfer case?

fyi 1990 4.2 5 speed

__________________
check out my build thread...BLUE BALLED BUILD
http://www.wranglerforum.com/f8/blue...ld-122927.html
mcseang is offline   Quote Quick Reply
Old 07-14-2013, 07:07 PM   #2
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 716
Did you remove the indicator switch and manually depress the contact? That will verify the the switch is actually working.

Defcon 1 is offline   Quote Quick Reply
Old 07-14-2013, 07:18 PM   #3
RUBISEAN

WF Supporting Member
 
mcseang's Avatar
 
Join Date: Sep 2011
Location: wesley chapel,fl
Posts: 399
Quote:
Originally Posted by Defcon 1 View Post
Did you remove the indicator switch and manually depress the contact? That will verify the the switch is actually working.
thanks, i'll give that a shot in the morning
__________________
check out my build thread...BLUE BALLED BUILD
http://www.wranglerforum.com/f8/blue...ld-122927.html
mcseang is offline   Quote Quick Reply
Old 07-15-2013, 09:04 AM   #4
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
are you sure your 4WD is actually working?
wasomma is offline   Quote Quick Reply
Old 07-15-2013, 09:35 AM   #5
RUBISEAN

WF Supporting Member
 
mcseang's Avatar
 
Join Date: Sep 2011
Location: wesley chapel,fl
Posts: 399
[QUOTE=wasomma;3963853]are you sure your 4WD is actually working?[/QUOTE
yes 4wd works as it should.... just no indicator light
__________________
check out my build thread...BLUE BALLED BUILD
http://www.wranglerforum.com/f8/blue...ld-122927.html
mcseang is offline   Quote Quick Reply
Old 07-15-2013, 01:34 PM   #6
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 716
You test the indicator switch yet? Be careful pulling the electrical connector off they usually get caked up with dirt and grease. You'll need an oversize wrench too to spin it out, I think it's around 7/8" or 22mm.
Defcon 1 is offline   Quote Quick Reply
Old 07-15-2013, 03:57 PM   #7
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,337
Images: 1
On a 90 you have the vac. switch on the firewall as you said. 91 and above it's on the driver's side of the actuator on the dif. and it's electric. With the ignition on, don't start it, if you remove and pull air on the vac. line that's attached to the switch the 4wd light should activate. Someone else will have to sit in the driver's seat to let you know because it will cycle on and off as you release air pressure. If it doesn't then it's the switch itself, the wire going from the switch to the dash or the bulb. But, if you already checked the bulb and you're sure it's ok then you can rule it out. Just to be sure, I would temporarily swap in a bulb that you know works. Most likely the vac switch over the wire into the harness if it still doesn't work. Just make sure it's definately not the bulb.
kik is offline   Quote Quick Reply
Old 07-15-2013, 04:01 PM   #8
Jeeper
 
michaelgoesrawr's Avatar
 
Join Date: May 2011
Posts: 21
I replied to your other thread on JF. I'm betting its something to do with the connections between the switch and the bulb. That is if I'm understanding your explanation


Sent from AutoGuide.com Free App

michaelgoesrawr is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:35 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC