'89 Islander sputters (loses power around 50 mph) - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-09-2009, 11:21 AM   #1
Newb
 
Join Date: Aug 2009
Location: Orlando
Posts: 2
Thumbs down '89 Islander sputters (loses power around 50 mph)

I have an '89 Jeep Islander, recently underwent a huge renovation project (transmission, timing chain, replaced rear seals/gaskets etc.) and was running great for several months.

However recently, it's been having trouble accelerating over 50 mph (sputters, hesitates and/or misfires). When I checked the spark-plugs I noticed greyish/white residue. I suspect that it may be the fuel pump (running lean - one of the only things still original left) but am confused as to why it would be at higher speed - wouldn't it occur potentially at all speeds?

Anybody else come across this?


whoneedsdoors? is offline   Quote Quick Reply
Old 08-09-2009, 11:34 AM   #2
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,840
Images: 1
What engine do you have? Carb. or FI. / Trans.

kik is offline   Quote Quick Reply
Old 08-09-2009, 11:37 AM   #3
Newb
 
Join Date: Aug 2009
Location: Orlando
Posts: 2
4.2 L (6-cyl) carb.
whoneedsdoors? is offline   Quote Quick Reply
Old 08-09-2009, 07:52 PM   #4
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,840
Images: 1
My 89 4.2 carb. 5 spd. did the same thing at low speed and it was the Ignition Control Module. A lot of times a lack of power could be a clogged cat. The fuel pump could not be providing enough fuel to the carb. as you increase speed. I would replace it. Unfortunately, there could be a number of problems; carb, fuel pump, distributor, coil, Ignition Control Module, Cat. Have you been loosing anti-freeze. If not your plugs are probably o'k. I would start with the fuel pump and go from there.
kik is offline   Quote Quick Reply
Old 08-09-2009, 08:04 PM   #5
after birthday glow
 
morphious's Avatar
 
Join Date: Jul 2009
Location: wisconsin
Posts: 1,963
Images: 1
fuel pump i had the same thing happen mine started at 65 and with in a month got to the point were if u tried to go faster then 25 it would sputter and miss and all that fun stuff just replace the pump
__________________
some say why i say
its a jeep thing u wouldn't understand
morphious is offline   Quote Quick Reply
Old 08-10-2009, 01:11 AM   #6
Jeeper
 
buckshot500's Avatar
 
Join Date: Mar 2009
Location: Carolina
Posts: 798
Remove vacuum line from EGR valve & plug the line there.

If it runs better, then you can either leave it that way, (as long as you have Nuttered) or whip out the $90.00 for a replacement.
__________________
90YJ 98XJ
buckshot500 is offline   Quote Quick Reply
Old 08-10-2009, 05:54 AM   #7
Jeeper
 
dos0711's Avatar
 
Join Date: Mar 2006
Location: Northeast Florida
Posts: 400
Does it still have a catalytic converter? Check to see if it's starting to get plugged up.

__________________
Jeepless at the moment...
dos0711 is offline   Quote Quick Reply
Reply

Tags
accelerate , loses power , misfires , sputters

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 YJ 2.5 Won't start, no power to the fuel pump eyeChrs YJ Tech Forum 15 02-14-2012 05:46 PM
No power acordell TJ Tech Forum 13 02-16-2010 07:26 AM
intermittant power to fuel pump skeeter General Jeep Discussion 4 02-08-2009 09:22 PM
Linear amp Question silvergoat Communications and Electronics 19 11-07-2008 06:11 PM
88 Wrangler loses power around 3500 rpm swansonsvette YJ Tech Forum 0 02-19-2007 05:47 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:09 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC