90 wrangler rough idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-14-2013, 10:12 PM   #1
Newb
 
Join Date: Sep 2013
Location: Pearson, ga
Posts: 2
90 wrangler rough idle

Hey guys, new to the site figured y'all could help me out before I burn this jeep. Bought it not running the guy said they played got it hot and was trying to rinse it off while iit was hot and it never started back but ran smooth before that.It's had the nutter bypass and the weber conversion and wires cut and spliced to hell and back. Replaced icm, distributor, cap, rotor, wires, intake and exhaust manifold gaskets, deleted the egr, and everything else I could possibly figure. It had a stuck valve but I got it back functioning( no bent pushrods) runs like crap at idle and shuts off when putting it in gear. Once it's in gear it runs slick with a miss every once in a while. Thought about going with the 2100 carb. Any advice would be appreciated.

Dave1112 is offline   Quote Quick Reply
Old 09-15-2013, 06:41 AM   #2
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,908
symptoms sound like a possible vacuum leak..check all the hoses first then maybe spray some carb cleaner around the base of the carb to see if the idle changes while you are spraying..if you had a stuck valve and just freed it up then chances are that is not fixed..I see that you are not far from me.I am about 25 miles south of Tifton

harleydragon is offline   Quote Quick Reply
Old 09-15-2013, 11:53 AM   #3
Newb
 
Join Date: Sep 2013
Location: Pearson, ga
Posts: 2
Ill give that a try. The only vacuum that hasn't been eliminated is the vacuum advance and the break booster and that was our first thought too. It still has a miss everyonce in a while under load which I figured was maybe the valve so that I can live with but the idle is unbearable. I did spray carb cleaner around where the linkage goes into the carb but not the base. Thanks for the help. So you're close to the moultrie/ adel area?
Dave1112 is offline   Quote Quick Reply
Old 09-15-2013, 12:01 PM   #4
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,908
yeah,7 miles west of Norman Park,out in the country
harleydragon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC