91 Stalling Issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-17-2008, 09:27 AM   #1
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
91 Stalling Issues

I recently purchased a 91. I have replaced the cap, rotor, plugs and wires. Cranks and idles fine. Runs great. When I am at speed, and put it into neutral to come to a stop, engine shuts off. Cranks right up with no problems. I have checked for vacuum leaks and can not find any. Any suggestions?

jdk92682 is offline   Quote Quick Reply
Old 03-17-2008, 09:30 AM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
check how dirty throttle body is, and possibly idle air control motor. nasty throttle bodies cause some problems in jeeps. just clean it while you're there.

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-17-2008, 01:53 PM   #3
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
if it is the 4.2 check the butterfly valve on the carb the bushings are natorious for going bad
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 01:56 PM   #4
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
91 should be 4.0 right? that's what i was banking on. if its 4.2 go the carb direction.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-17-2008, 02:02 PM   #5
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
seen some that were 4.2 and some 4.0 kinda depends on the mfg date if it is 4.0 check the map on the fire wall make sure it has a constant vac source
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 02:24 PM   #6
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
It is a 4.0!!!
jdk92682 is offline   Quote Quick Reply
Old 03-17-2008, 02:37 PM   #7
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
Quote:
Originally Posted by jdk92682 View Post
It is a 4.0!!!
check the map sensor on the fire wall make sure it has a vac line hooked up to the intake if all this looks good youll have to see if you can get any codes out of the comp to do this turn the ignition on then off do this four times (i think) then leave it in the on position and keep track of the check engine light count the blinks it should start with "12" this is not a code good luck
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 03:12 PM   #8
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
So I tried the ignition sequence and came up with 30 blinks. Not to sure what that really means?
jdk92682 is offline   Quote Quick Reply
Old 03-17-2008, 03:32 PM   #9
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
check here
http://www.jedi.com/obiwan/jeep/dtc.html
it should help (i hope)
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 05:17 PM   #10
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
Alright, so I have run the codes and 12, 33, 15, and 41 came up.
12 - nothing to worry about
33 - Air Condition Clutch Relay - nothing to worry about do not have air cond
15 - Distance sensor or ciruit - any suggestion on fixes
41 - Alternator Field - any suggestion on fixes
jdk92682 is offline   Quote Quick Reply
Old 03-17-2008, 05:22 PM   #11
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
obd 1 sucks, those codes could send you on a wild goose chase. i'm a mechanic and i've never heard of a distance sensor, unless there's another name for it. try the basics.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-17-2008, 09:51 PM   #12
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
"15** No vehicle distance (speed) sensor signal detected during road load conditions" check wires going to the speed sensor if they are good you probably need a new one

41* An open or shorted condition detected in the generator field control circuit you need to get your alternator tested and probably replaced

good luck hope this helps
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 09:55 PM   #13
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
aaahhh, vehicle speed sensor. computer wants to know how fast your goin. could act weird with no vehicle speed input. charging problems make computers freak out to.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-17-2008, 10:06 PM   #14
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
Quote:
Originally Posted by jpdocdave View Post
aaahhh, vehicle speed sensor. computer wants to know how fast your goin. could act weird with no vehicle speed input. charging problems make computers freak out to.
knowing these things the main cause of the stalling would be the alternator the comp needs a constant 13 or volts or it crys like a baby!
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 10:18 PM   #15
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
yep, gotta make sure computer is getting its juice right first.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-18-2008, 07:59 AM   #16
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
Thanks guys for the help, I am going to have the alternator tested hopefully tonight? I'll keep you all informed.
jdk92682 is offline   Quote Quick Reply
Old 03-18-2008, 12:08 PM   #17
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
good luck
spazinweasel is offline   Quote Quick Reply
Old 03-19-2008, 08:42 AM   #18
Newb
 
Join Date: Mar 2008
Location: Ocala, Fl
Posts: 6
alternator benched tested fine, I don't know at this point. I have to be overlooking something!
jdk92682 is offline   Quote Quick Reply
Old 03-19-2008, 02:00 PM   #19
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
id say it could be itermitant problem id say clear the codes (dissconnect batt for 30 sec.) see if it comes back

spazinweasel is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unexplained engine stalling and starter sticking labwagn JK General Discussion Forum 10 06-25-2012 12:12 PM
Engine Issues.... CimJeep TJ Tech Forum 1 01-16-2009 05:32 PM
ive got issues! 4bangertj TJ General Discussion Forum 42 11-02-2007 12:20 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC