91 wrangler 4cyl will crank but wont run sputtrs backfires - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-28-2010, 02:58 PM   #1
Newb
 
Join Date: Jun 2010
Posts: 3
91 wrangler 4cyl will crank but wont run sputtrs backfires

Im working on a friends 91 wrangler that has sat up for two years bcause it needed a crank position sensor i drove the jeep for bout an hour after replacig sensor and it started stalling a little bit and then the stalling turned into bogging and sputtering and if you floor board it it would backfire bad i think the gas in it is bad and had water in it or maybe the fuel filter is clogged up now it will turn over and crank for a second but wont run but maybe 10seconds then dies and is hard to crank u have to mash the pedle to the floor then it cranks and misses and backfires n any help would be appreciated im not very familiar with these jeeps

penman is offline   Quote Quick Reply
Old 06-28-2010, 04:04 PM   #2
Jeeper
 
flatline's Avatar
 
Join Date: May 2010
Location: pinole ca.
Posts: 680
Images: 3
sounds like bad fuel, now you could have clogged injectors. could try fresh gas and some gas dry. may need to try some diffrent injectors. cheap way to go is to pull out of a ford 5.0/4.6 they swap into the 6cylinder should be the same for the 4.

flatline is offline   Quote Quick Reply
Old 06-28-2010, 04:52 PM   #3
Newb
 
Join Date: Jun 2010
Posts: 3
took both sensors of throttlebody and poored gas in the tb and would run for 30 secnds i think its those sensos or bad gas still is their a gas tank drain or do i have to drop the tank and whats gas dry
penman is offline   Quote Quick Reply
Old 06-28-2010, 05:33 PM   #4
Jeeper
 
flatline's Avatar
 
Join Date: May 2010
Location: pinole ca.
Posts: 680
Images: 3
Pump or siphon out as much gas as you can. put in 5 gallons of fresh gas. gas dry is basically rubbing alcohal. you can find it at any parts store. could also put in some good injector cleaner and hope. change out the filter after putting in good gas. I don't think the sensors are bad, just the gas.
flatline is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 wrangler backfires vachonz YJ Tech Forum 2 08-02-2009 09:54 AM
2008 Wrangler Purchase soupy1957 JK Pics Forum 23 11-22-2007 04:48 AM
First Wrangler - 3rd Jeep!!! tritonman WF New Member Check In 10 09-28-2007 08:27 AM
Window Crank woes, did any one else have this problem? virtual_verve11 JK Tech Forum 2 04-07-2007 09:57 AM



» Featured Product

All times are GMT -5. The time now is 01:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC