91 YJ 2.5 fuel problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-23-2013, 05:16 AM   #1
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
91 YJ 2.5 fuel problems

Started with the TPS. Replaced exhaust manifold/intake gasket, water inlet gasket and throttle body gasket. New plugs gaped at .35 and new coolant. After I put it all back together there is no fuel getting to the rail. There is pressure when I open the relief valve but no fuel. I can also hear the fuel pump kick on when I turn the key. I'm stumped. Looking at hoses today and filter. What else should I check?

Shawnbn is offline   Quote Quick Reply
Old 12-23-2013, 06:43 AM   #2
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 723
Quote:
Originally Posted by Shawnbn View Post
Started with the TPS. Replaced exhaust manifold/intake gasket, water inlet gasket and throttle body gasket. New plugs gaped at .35 and new coolant. After I put it all back together there is no fuel getting to the rail. There is pressure when I open the relief valve but no fuel. I can also hear the fuel pump kick on when I turn the key. I'm stumped. Looking at hoses today and filter. What else should I check?
Rent a fuel pressure rail gauge. That will tell you for sure if fuel is getting to there. It needs to prime at like 35 psi. If you said the fuel pump kicks on when you key-on, it's possible that it's not putting out enough pressure (bad fuel pump) or there is a clog/kink in the lines.

After spending 3 months trying to figure out why my fuel pump wouldn't prime or run in my '91 2.5, unfortunately I'm pretty knowledgable about this subject lol.

Defcon 1 is offline   Quote Quick Reply
Old 12-23-2013, 07:28 AM   #3
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
Will do. It's been rough. Just came out of knee surgery and not looking forward to laying under it to drop the tank.
Shawnbn is offline   Quote Quick Reply
Old 12-23-2013, 07:37 AM   #4
Jeeper
 
peety's Avatar
 
Join Date: Feb 2013
Location: Almost a PINEY...
Posts: 225
What exactly is the Jeep NOT doing ???
__________________
Patience and perseverance have a magical affect before which difficulties disappear and obstacles vanish.

John Quincy Adams
peety is offline   Quote Quick Reply
Old 12-24-2013, 01:57 AM   #5
Jeeper
 
nicco196's Avatar
 
Join Date: Dec 2013
Location: Ninety Six, SC
Posts: 62
Check the fuel filter. Out of no ware My 91 yj quit on Me the other day. Completely clogged. Bought a new one. Tossed it on and wouldn't turn over. No fuel gettin through the lines. I started checkin things after it finally turned over but wouldn't idle. IAC was shot. Went and bought another one. But fuel still wasn't gettin through the lines. Things didn't quite line up with the new filter. I actually had to bend the fuel lines but it fired right up
nicco196 is offline   Quote Quick Reply
Old 12-24-2013, 02:03 AM   #6
Jeeper
 
nicco196's Avatar
 
Join Date: Dec 2013
Location: Ninety Six, SC
Posts: 62
Typo. My yj is a 92
nicco196 is offline   Quote Quick Reply
Old 12-24-2013, 04:17 AM   #7
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
It's not starting at all and no fuel is getting to the rail. I am getting some pressure but it sure isn't the right pressure. I am changing the filter, pump and putting new lines in.
Shawnbn is offline   Quote Quick Reply
Old 12-24-2013, 09:31 AM   #8
Jeeper
 
nicco196's Avatar
 
Join Date: Dec 2013
Location: Ninety Six, SC
Posts: 62
Mine was the same way. Try cutting the switch back and forth for a while not actually tryin to crank but just so the pump will turn on. Everytime you do that it should eventually build your fuel pressure back up. Just check pressure after every couple times doin this.
nicco196 is offline   Quote Quick Reply
Old 12-26-2013, 08:51 AM   #9
Jeeper
 
peety's Avatar
 
Join Date: Feb 2013
Location: Almost a PINEY...
Posts: 225
Quote:
Originally Posted by Shawnbn View Post
It's not starting at all and no fuel is getting to the rail. I am getting some pressure but it sure isn't the right pressure. I am changing the filter, pump and putting new lines in.
Will it start with an Ether shot ?
__________________
Patience and perseverance have a magical affect before which difficulties disappear and obstacles vanish.

John Quincy Adams
peety is offline   Quote Quick Reply
Old 12-29-2013, 06:01 AM   #10
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
Update. Fuel pump shot and fuel lines rotted. Replacing and will let yall know if it's back running.
Shawnbn is offline   Quote Quick Reply
Old 01-15-2014, 07:56 PM   #11
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
Well everything's back together. I have fuel at the rail, new plugs, new tps, and when I went to start it nothing. Turned over and sputtered and that's it. Gave it a shot of ether and still nothing but sputtering. Battery level was reading 8 volts on the dash. So I am charging the battery. Took #1 plug out and compression is reading just shy of 180. Why won't it run?
Shawnbn is offline   Quote Quick Reply
Old 01-16-2014, 08:11 AM   #12
Jeeper
 
Shawnbn's Avatar
 
Join Date: Oct 2013
Posts: 25
Good and bad news. Jeep is running. It was a dead battery. But on the other hand while at idle it started to sputter out until I hit the gas. Any ideas?
Shawnbn is offline   Quote Quick Reply
Old 01-20-2014, 11:40 PM   #13
Jeeper
 
nicco196's Avatar
 
Join Date: Dec 2013
Location: Ninety Six, SC
Posts: 62
Iac
nicco196 is offline   Quote Quick Reply
Old 01-20-2014, 11:40 PM   #14
Jeeper
 
nicco196's Avatar
 
Join Date: Dec 2013
Location: Ninety Six, SC
Posts: 62
Maybe haha

nicco196 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC