92 Wrangler Slave Cylinder Misery - HELP!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-23-2007, 03:53 PM   #1
Newb
 
Join Date: Jul 2007
Location: Casper, Wyoming - USA
Posts: 2
Unhappy 92 Wrangler Slave Cylinder Misery - HELP!!!

I have a 1992 Jeep Wrangler with a 2.6L 4 Cylinder with a 5 speed transmission. I bought the Wrangler used from a local dealer in my area. I have had the Jeep for about one year. During that year, I have replaced the clutch slave cylinder 3 times. I now have my 4th slave cylinder on order and I am dreading a 4th teardown and re-install. I would like to know if there's any additional factors that might be causing this problem to occur. I have flushed the hydraulic system twice now and found no signs of oil contamination. If anybody knows what's wrong or what the solution is please let me know. THANKS!

wyoming92 is offline   Quote Quick Reply
Old 08-21-2007, 02:36 PM   #2
Newb
 
Join Date: Jul 2007
Location: Casper, Wyoming - USA
Posts: 2
1992 YJ Clutch Slave Cylinder Problem - Need Suggestions!

I have a 1992 Jeep Wrangler with a 2.5 4 Cylinder with a 5 speed transmission. I bought the Wrangler used from a local dealer in my area. I have had the Jeep for about one year. During that year, I have replaced the clutch slave cylinder 3 times. I now have my 4th slave cylinder on order and I am dreading a 4th teardown and re-install. I would like to know if there's any additional factors that might be causing this problem to occur. I have flushed the hydraulic system twice now and found no signs of oil contamination. If anybody knows what's wrong or what the solution is please let me know. THANKS!

wyoming92 is offline   Quote Quick Reply
Old 08-21-2007, 03:52 PM   #3
Jeeper
 
reevesdieselyj's Avatar
 
Join Date: Aug 2007
Posts: 231
I just went through the same thing. I put my clutch and slave cylinder in 2 days before I headed on a 600 mile trip. About half way home I started loosing my fluid. turns out it was leaking from the oring were the hard line goes into the slave cylinder I put 2 orings were one is supposed to go and put her back together. I am baffled on why it started leaking. everything was brand new. Have you checked to see what kind of brake fluid it takes. Maybe we are using the wrong grade. best of luck.
-Aaron-
reevesdieselyj is offline   Quote Quick Reply
Old 08-21-2007, 07:28 PM   #4
Jeeper
 
Jeep_Geek's Avatar
 
Join Date: Aug 2007
Location: Omaha NE
Posts: 382
I have a 92 4cyl also and am on the third slave cylinder. I am also baffled to why they go out. This last one I bought it with a lifetime warranty at auto zone and it has lasted for 15,000 miles so far. The original one went for 95k and the second one lasted for 5,000 miles ...
My AX-5 trans also blew up three times
Thats why I am currently swapping to a NV4500

Good luck is all I can say

Oh yeah its DOT3 brake fluid is what I was told to use ........just the standard stuff
Jeep_Geek is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 7 08-30-2014 06:36 AM
Slave Cylinder Mod for Tranny Swap tn-yj YJ Tech Forum 1 12-11-2008 08:45 PM
Busted slave cylinder Brewski TJ General Discussion Forum 16 04-01-2008 08:37 AM
Slave Cylinder femmedemer07 YJ Tech Forum 3 03-28-2007 03:51 PM



» Featured Product

All times are GMT -5. The time now is 09:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC