92 YJ ECU Fuel System fuse keeps blowing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-22-2011, 04:17 PM   #1
Newb
 
Join Date: Dec 2011
Posts: 11
92 YJ ECU Fuel System fuse keeps blowing

Hello, I'm at a lost and can't figure out where to go and check. Looking for some tips or things to look for.

Vehicle:
1992 Jeep 6 cyl 5 speed
128k
Just bought two months ago.

Jeep ran perfect prior to yesterday morning, I got in started it up, it drove 3 feet and the engine turned off. I attempted to restart and i just hear the starter turning over. Check Engine Light came on as well as the upshift light.

Fuse by the battery "ECU FUEL SYS 30a" is blown.
Replaced fuse. Vehicle starts right up. Idles perfectly. Put in gear, drive two feet, vehicle shuts off, that fuse is again blow.

Replaced fuse, let idle, idles perfect. Rev'd a few times, perfect. turned key off. Tried to turn back on. bam blown fuse.

At $5.50 a fuse, this is becoming an expensive annoyance.

I pulled CHECK ENGINE CODES
12, 33, 55 = Battery, A/C ( there is no a/c in this jeep), 55 end of codes.

Things I've checked.
Fuel pump prime sound when key turned to run -good.
Wires around engine bay all seem in good condition.
Wires going to o2 sensor seem ok to the eye.

Where and what should I be looking for now? What should I test? Any help would be much appreciated.

cougarcruisin is offline   Quote Quick Reply
Old 12-23-2011, 12:44 AM   #2
Jeeper
 
Jeep716's Avatar
 
Join Date: Aug 2010
Posts: 397
Might be bad fuel pump. As mine was letting go it was humming loud, volts would intermittently drop, and Random prime and no start. Replaced pump and no issues now. Just bring the old one in to match it up. There are a few different ones. Not a fun or easy job if you don't have a lift. Did it on my back in the dark in my driveway. Lol. It's definitely a Jeep thing

Jeep716 is offline   Quote Quick Reply
Old 12-23-2011, 03:45 PM   #3
Newb
 
Join Date: Dec 2011
Posts: 11
Update:
I pulled ecu, and it appears to have no brown or black outs. Everything "looks" normal. I do not see any breaks or tears in wires going to ecu.

Anyone know where I can get a maxi 30amp breaker? The maxi fuse's at advance auto are $5.50 a piece.
cougarcruisin is offline   Quote Quick Reply
Old 12-23-2011, 03:51 PM   #4
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
not sure on the breaker, but with it rolling and blowing a fuse each time it moves try this. Replace the fuse, start it but don't roll. Let it run then get out and push on a fender a few times to shake the jeep. If you do that, and it blows, then there is water somewhere it isn't supposed to be. Or a loose wire stripped hitting ground when shaken.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 12-23-2011, 06:55 PM   #5
Newb
 
Join Date: Dec 2011
Posts: 11
Thanks for the advice, it has rained every night since the problem first started.
cougarcruisin is offline   Quote Quick Reply
Old 01-10-2012, 09:58 PM   #6
Newb
 
Join Date: Dec 2011
Posts: 11
Ok... The jeep is at a mechanics garage, the best in the area when it comes to working on Jeeps. Bad thing is the best mechanic means long waits due to high traffic. So the yj has been there for over a week now, still waiting its turn.

I bought ALL NEW RELAYS to rule those out.

Jeep starts right up, no problem. Idles perfect. Allowed it to warm up to temperature. Put it in 1st, let off the clutch, moved 2 inches and bam shut off.

I jumped out, replaced the blown 30a maxi ecu fuel sys fuse with my other spare that I bought.

I jumped back in, put it in reverse, clutch grabbed, moved about 2 inches, bam shut off.

What in the world could this be?
cougarcruisin is offline   Quote Quick Reply
Old 03-20-2012, 09:49 PM   #7
Jeeper
 
Join Date: Jun 2010
Location: Michigan
Posts: 62
Images: 9
sorta having the same problem except when my fuse blew it died and won't start, keeps eating fuses...fuel pressure is good, no noticeable bare wires, what I do have is a leaking injector,,,it's leaking right out of the top where the electric plug is. unplugged all the injectors, didn't blow fuse, plugged in the leaker and blew the fuse. Hopefully the new infector will do the trick.....
tazmangk is offline   Quote Quick Reply
Old 09-23-2013, 05:29 PM   #8
Jeeper
 
Shadeemry's Avatar
 
Join Date: Aug 2010
Posts: 101
Quote:
Originally Posted by cougarcruisin View Post
Ok... The jeep is at a mechanics garage, the best in the area when it comes to working on Jeeps. Bad thing is the best mechanic means long waits due to high traffic. So the yj has been there for over a week now, still waiting its turn.

I bought ALL NEW RELAYS to rule those out.

Jeep starts right up, no problem. Idles perfect. Allowed it to warm up to temperature. Put it in 1st, let off the clutch, moved 2 inches and bam shut off.

I jumped out, replaced the blown 30a maxi ecu fuel sys fuse with my other spare that I bought.

I jumped back in, put it in reverse, clutch grabbed, moved about 2 inches, bam shut off.

What in the world could this be?
alot of people wanting to know how this turned out, can you please update us on what happened?
Shadeemry is offline   Quote Quick Reply
Old 09-25-2013, 09:31 AM   #9
Jeeper
 
Join Date: Jan 2013
Posts: 212
Sounds like you have a direct ground that is blowing the fuse. I would check under the dash near the clutch pedal. Sounds like there might be a wire rubbing under the dash when the clutch is released, causing the ground. Let us know what you find.

__________________
1991 YJ 4.0L, K&N air filter, SS headers, 31X10.5, Congo Cage, etc...
CMike357 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Vehicle Information Center Mikial JK General Discussion Forum 15 01-12-2012 12:14 PM
Fuel system troubles scifibassman TJ General Discussion Forum 3 09-12-2011 10:22 AM
I keep Blowing the SAME Fuse ! Help talon_john TJ General Discussion Forum 28 03-05-2011 08:25 AM
The effects of ethanol gas on a Jeep 95jeepthing YJ General Discussion Forum 37 12-28-2010 05:31 PM
No power to my fuel system? the idiot magnet YJ Tech Forum 3 03-18-2007 04:27 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC