92 YJ Wrangler sputtering problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-22-2008, 05:33 PM   #1
Newb
 
Join Date: Oct 2008
Location: Western Ma
Posts: 14
92 YJ Wrangler sputtering problem

Hi Guys.
Another gremlin in this thing. Starting 2 days ago I let the fuel tank get very low, I filled up at a gas station that I had always got gas. The engine will lose power whenever. I at first thought it mut be bad gas. I changed my fuel filter and checked it for water, there was alittle. I've gone thru 2 tanks of gas and a bottle of gas line antifreeze. Today driving home it did it again, it loses all power and back fires. I am now leaning towards ignition system, I bought some new bosch plugs and I am going to trash the Champs. Anyone have any suggestions on where to start. I have not determined if it will do it not under load, also I don't have an engine light on.
Any help is appreciated, this is my fun toy.
Chris

Methanepower is offline   Quote
Old 12-23-2008, 01:25 AM   #2
Jeeper
 
Join Date: Aug 2008
Location: westminster
Posts: 291
Send a message via Yahoo to punkafi888
ugg trash the bosch crap! i worked at a parts store for 3 years and specialise in ignition. usually the cheapest plugs you get are the best. if you can get the ngk plug they tend to work well in generally every thing. check your coil, wires and cap and rotor.

__________________
94 yj, 4" procomp lift, 3" body lift, sliders, cshr corners, d44 e locker rear swap, 35" bfg at's, 4.10 gears, crown 7 layer brake lines, jks discos, jks track bar disco, 97cherokee 4.0 swap.
next up twizted soa full widths. 14bolt and dana44
colorado, home of the insane
http://www.cardomain.com/ride/3144433
punkafi888 is offline   Quote
Old 12-23-2008, 01:53 PM   #3
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 5,990
Check out (89 Wrangler 4.2 need help) to see if it applies.
kik is offline   Quote
Old 12-23-2008, 04:11 PM   #4
Newb
 
Join Date: Oct 2008
Location: Western Ma
Posts: 14
I relized after posting this I was one of those guys that did not take advantage of all the other great post on here, before asking the same question that has been answered several time already. I am going to pick up a set of the NGK plugs, I run large industrial engines that burn methane, you would not believe the diffrence in plugs. I have a new O/2 in the box, it isn't doing any good there. I am hoing for a few minutes over the holiday to install it. I'll let you all know of any improvments. I've attached a oicture of my snow beast.
Chris
Attached Thumbnails
Click image for larger version

Name:	DSC02408 (Small).JPG
Views:	4
Size:	67.1 KB
ID:	5702  
Methanepower is offline   Quote
Old 12-23-2008, 05:43 PM   #5
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
clean the tb sensors too
__________________
89 yj 4.0 conversion 89 grand waggy tbi
spazinweasel is offline   Quote
Old 12-31-2008, 05:35 PM   #6
Newb
 
Join Date: Oct 2008
Location: Western Ma
Posts: 14
Hi Guys,
I changed out the plugs, the old ones had about 1000 miles on them. There is a huge diffrence in the throttle and it runs a little smoother. I have a new TPS coming, hopefully this weekend it will make it in. Lots of snow here today, nothing better than a jeep in the snow.
Chris
I also replaced the vacuum switch on the front axle, it wasn't always engaging. I found a ton of water in the diaphram that would freeze on cold days, like when there is snow on the ground and you need it to work.

Methanepower is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
fuel pump problem in jeep wrangler to chevy engine conversion guardian YJ Tech Forum 8 11-11-2008 02:44 PM
Wrangler water cooler problem? madimi TJ Tech Forum 6 10-20-2008 05:35 AM
Heater / Blower Problem 2000 Wrangler dougman1971 TJ Tech Forum 0 09-17-2008 07:56 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:56 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC