93 Charging issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-15-2013, 06:23 PM   #1
Newb
 
Join Date: Apr 2013
Posts: 1
Exclamation 93 Charging issues

My '93 is having issues with charging. I installed a new alternator, and the battery is new (and tested fine), but it's running still at only 11.63 volts and slowly dropping (while running). I took it to Advanced auto and they told me the voltage regulator is probably bad. I know the alternator is externally regulated, but he said it was going to be the computer? ($300) Has anybody had this issue before, and could tell me how to solve it? I need to fix it by early May so I can drive it back home from school. Also, If anybody could let me know, is the voltage regulator the small black box on the back of the alternator?

Other possibly relevant info, it is a 4L, and most parts are stock. The belt has enough tension. Revving the engine causes it to drop a little faster. turning on lights makes the guage drop a few volts (fog lamps even more so) but the voltage goes up after turning them off. I also have access to one of the school garages, with more tools than I'll ever need. (including some electrical equipment)

Thanks for the help and advice,

Dan.

CGWizard is offline   Quote Quick Reply
Old 04-15-2013, 06:40 PM   #2
Jeeper
 
Redrider94's Avatar
 
Join Date: Aug 2010
Posts: 633
Quote:
Originally Posted by CGWizard View Post
My '93 is having issues with charging. I installed a new alternator, and the battery is new (and tested fine), but it's running still at only 11.63 volts and slowly dropping (while running). I took it to Advanced auto and they told me the voltage regulator is probably bad. I know the alternator is externally regulated, but he said it was going to be the computer? ($300) Has anybody had this issue before, and could tell me how to solve it? I need to fix it by early May so I can drive it back home from school. Also, If anybody could let me know, is the voltage regulator the small black box on the back of the alternator?

Other possibly relevant info, it is a 4L, and most parts are stock. The belt has enough tension. Revving the engine causes it to drop a little faster. turning on lights makes the guage drop a few volts (fog lamps even more so) but the voltage goes up after turning them off. I also have access to one of the school garages, with more tools than I'll ever need. (including some electrical equipment)

Thanks for the help and advice,

Dan.
The regulator is part of the ECM, so if it's bad then you need to replace the ECM. You could research how to wire an external regulator to your alternator, it can be done.

Redrider94 is offline   Quote Quick Reply
Old 04-16-2013, 11:00 AM   #3
Jeeper
 
AV8R's Avatar
 
Join Date: Mar 2012
Location: North Georgia USA
Posts: 444
Check all of your ground connections. Remove, clean, and reattach. Then see what ya got.
AV8R is offline   Quote Quick Reply
Old 04-16-2013, 11:05 AM   #4
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Make sure all the connections at the ECM are clean and secure too.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 06-10-2013, 07:53 AM   #5
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
and check over your wiring harness and be sure all connections are clean/tight and that the green wire running from the alternator to the ECM did not wear through anywhere...
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Reply

Tags
charging , ecu , problems , voltage regulator , wiring

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:44 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC