93 YJ 4.0L trouble starting (must put gas pedel to the floor) - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-21-2012, 10:58 PM   #1
Jeeper
 
206dawgfan's Avatar
 
Join Date: Mar 2010
Location: Shoreline
Posts: 77
206dawgfan is on a distinguished road
93 YJ 4.0L trouble starting (must put gas pedel to the floor)

I have a 1993 4.0L YJ that I am having a tuff time getting it started. I can get it started, but to do so I must put the gas pedel to the floor. I dont have to do it every time just 95% of the time, so pretty much every time. Once started it runs prefect other than it kinda has a low idle. I have changed spark plugs and wires, cap and rotor and changed the fuel and air filter. Any help would be great.
206dawgfan is offline   Quote
Old 01-22-2012, 10:03 PM   #2
Jeeper
 
yjmark's Avatar
 
Join Date: Dec 2011
Posts: 322
yjmark is on a distinguished road
try changing fuel filter. drivers side rear wheal well

yjmark is offline   Quote
Old 01-22-2012, 10:50 PM   #3
Jeeper
 
Bobinayj's Avatar
 
Join Date: Jan 2012
Location: Pie Town, New Mexico
Posts: 78
Bobinayj is on a distinguished road
You may also want to check the O2 sensor
__________________
93 YJ still has a few original parts - very few
Bobinayj is offline   Quote
 
Old 01-23-2012, 05:07 AM   #4
Jeeper
 
Join Date: Dec 2011
Posts: 172
anamorph is on a distinguished road
Your fuel pressure regulator has gone bad. It is located at the front of the fuel rail. Had the same problem myself. It is about the size of a half dollar with a single hose leading to it. They are about $90. Good luck!
anamorph is offline   Quote
Old 02-26-2012, 06:50 PM   #5
Jeeper
 
206dawgfan's Avatar
 
Join Date: Mar 2010
Location: Shoreline
Posts: 77
206dawgfan is on a distinguished road
Quote:
Originally Posted by theamazingbeas
Your fuel pressure regulator has gone bad. It is located at the front of the fuel rail. Had the same problem myself. It is about the size of a half dollar with a single hose leading to it. They are about $90. Good luck!
Thanks for the help, I'll give it a shot
206dawgfan is offline   Quote
Old 02-26-2012, 07:47 PM   #6
Jeeper
 
stephenson121588's Avatar
 
Join Date: May 2009
Posts: 37
stephenson121588 is on a distinguished road
I had a 4.0 doing the same thing, I changed the throttle control sensor and idle control sensor and fixed the problem, easy to replace, if the regulator does not work try the sensors.

stephenson121588 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 wrangler DCNKY TJ General Discussion Forum 14 05-01-2010 08:37 PM
93 4.0L starting problems...HELP!! hondadbing116 YJ Tech Forum 6 02-07-2009 05:24 PM
00 wrangler 4.0L starting Ej132 TJ Tech Forum 2 01-20-2009 05:22 PM
intresting info on the 4.0L TB swap... foxinthemudd General Jeep Discussion 10 03-10-2008 11:37 PM
98 4.0L starting problem khunt8211 TJ Tech Forum 16 04-18-2007 07:47 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:16 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner