94 dd problems... random lights - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-21-2011, 09:19 AM   #1
Jeeper
 
Join Date: Apr 2011
Location: appleton
Posts: 41
94 dd problems... random lights

so on monday on my way home my water pump took a shit... its a 94 yj 4.0 5 spd... so got that fixed.. tuesday on my way to work witch is 40 miles away... brake light comes on... the one in the dash.. but is dim at first and sometime would go out or flash really fast... but now it is fully lit all the time.. so today i head out ot my shop and my speedo doesnt work... then right as i pull up the cel turn on... so i pull it in run the code and sure shit speedo signal bad or w/e... figure speed sensor.. and it also tells me something about the a/c circuit bad. even though ac was never on my jeep from the factory... but now my speedo is working when i left.. didnt even touch it.. and the brake light is on, and the up shift light always stays on now... the jeep does have abs in witch i unplugged it and pulled all the fuses and relays for..

what i have done

for the brake light i have unplugged the ebrake switch, proportiaing valve switch, brake booster switch or sensor thing and the light still stays on.. i topped my fluid off and it still contiues to stay lit...

as far as the speed sensor i am going to assume it is just a intermittent problem...

and the up shift light who knows...
then yesterday on my way back from work the shift light worked properly and the brake light went out but was replaced with the seatbelt light.. but sometimes the brake light would turn on and then the brake and the seatbelt light would both be dim...

im thinking maybe a grounding issue.

any help is apperciated...

shin is offline   Quote Quick Reply
Old 04-21-2011, 09:49 AM   #2
Jeeper
 
Join Date: Apr 2011
Location: Yermo California
Posts: 15
I have an 88 And Never had the upshift light, but I have had the 4x4 light stay on for like a week! (and I know it wasnt in 4x4) Heres what I can say... I know its a pain in the ass... But you need to check all your fuses... Then there should be like actual wires running from the E brake... maybe under ur carpert to, check to make sure your wire isnt stripped at all and touching your frame.. It helped me.. But like I said mine is almost 10 years older than yours.. Hope this helps..

vans661 is offline   Quote Quick Reply
Old 04-21-2011, 11:07 AM   #3
Jeeper
 
Join Date: Apr 2011
Location: appleton
Posts: 41
will do.. i checked the fuses they were good... so then i left the ignition on and started to pull fuses and it went out when i pulled the ign/lps fuse and went back on when i put it back in...just a little fyi i guess
shin is offline   Quote Quick Reply
Old 04-22-2011, 01:41 AM   #4
Jeeper
 
Join Date: Apr 2011
Location: Yermo California
Posts: 15
check those wires they must cross somewhere and be touching, wrap those and i bet that will fix the problem.. hope this helps
__________________
A Monkey can do it! He just needs special tools.. Tarzan...
vans661 is offline   Quote Quick Reply
Old 04-23-2011, 09:44 AM   #5
Jeeper
 
Join Date: Apr 2011
Location: appleton
Posts: 41
now its all back to working fine... wierd
shin is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KC vs. Hella Lights jkrubicon JK General Discussion Forum 24 11-07-2011 01:10 AM
fog light question... Jaydogg25 YJ General Discussion Forum 17 08-05-2009 03:49 PM
Instrument cluster lights Jon H YJ General Discussion Forum 4 06-24-2009 05:11 PM
Installed My Backup Lights YellowRubiU TJ General Discussion Forum 11 12-07-2006 09:11 PM
if you have 4 Hella 500 lights. 2 are the driving lights and 2 are the fogs lights wh jjock TJ General Discussion Forum 2 12-05-2006 09:15 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC