94 very weird problem!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-03-2013, 02:02 PM   #1
Newb
 
Join Date: Apr 2012
Posts: 3
94 very weird problem!!!

Hey all! I'm having a super weird problem with my 94 YJ 2.5L. It started a few weeks ago and has gotten worse. While I'm driving the engine shuts off, I have to turn the ignition off, wait 30 seconds to 1 minute and it starts right back up and runs fine! I've narrowed the problem down to a fuel issue, my fuel pump intermittently does not get power. I determined this by running a wire from the fuel pump wires to the dash with an LED light. When the Jeep stalls the light goes out indicating no power to the fuel pump. Normally when starting it, the fuel pump does not come on just when turning the key to ON, it has to be starting. In the beginning it would happen every few days, but now its happening every couple minutes. I'm thinking it may be the fuel shut off sensor, but I'm having a real hard time finding wiring diagrams or information about that. Any other ideas or suggestions? I'm getting so frustrated! I'm a full time student and I work full time so I really need to fix this and fast. Thanks!!

amandazzle420 is offline   Quote Quick Reply
Old 09-03-2013, 03:35 PM   #2
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,274
Under the hood in the distribution box by the battery there are 2 relays you want to check. One is the AutoShutdown and the other is an ign relay. Check these and make sure they are not causing the issue. Just swap them out with your horn and or A/C clutch fan relays and try again.

AllMudd is online now   Quote Quick Reply
Old 09-04-2013, 12:58 PM   #3
Newb
 
Join Date: Apr 2012
Posts: 3
Thanks for the reply, I will definitely try that. I wasn't sure a relay would cause an intermittent problem like the one I'm having but it can't hurt to try! I'm also thinking the ECU may be losing ground, or causing the problem. I would really like to know what logic the ECU uses to determine if it should shut off the fuel pump.
amandazzle420 is offline   Quote Quick Reply
Old 09-04-2013, 03:10 PM   #4
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,275
While you have them shake and listen for a rattle. No rattle install. If the rattle the leaves of the relay are broken.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 09-05-2013, 02:25 PM   #5
Newb
 
Join Date: Apr 2012
Posts: 3
No rattle in the relays and swapped both the fuel pump relay and the auto shut off relay, same problem. I have also replaced the gasket between the pump and tank. Does anyone know how the ECU decides to shut off the fuel pump? as in, what's its logic?
amandazzle420 is offline   Quote Quick Reply
Old 09-06-2013, 03:07 AM   #6
Jeeper
 
Join Date: Aug 2009
Location: Hinesville, Ga
Posts: 219
There is a relay mounted to the firewall just to the right of your battery. Pull that relay and check and clean the connectors. My 94 2.5 did almost the same thing, once I found this relay the problem disappeared.

tim2 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:59 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC