94 wrangler 4cyl. feeles like flooding when give it gas - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-20-2011, 08:44 AM   #1
Newb
 
Join Date: Mar 2011
Posts: 7
94 wrangler 4cyl. feeles like flooding when give it gas

94 4cyl. when i give it gas it feels like flooding. I have changed the inectors,fuel pump,fuel filter, o2 sensor,tps,coolant sensor, cap, rotor,plugs and wires but still when you give it gas it will have a flooding out feeling someone please help

osucowpoke is offline   Quote Quick Reply
Old 03-20-2011, 11:02 AM   #2
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
any codes?

__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 03-20-2011, 11:05 AM   #3
Jeeper

WF Supporting Member
 
99jeeper's Avatar
 
Join Date: Feb 2011
Location: nothern michigan
Posts: 449
Images: 3
notice any black smoke like its running rich?change any air sensors?
__________________
99jeeper is offline   Quote Quick Reply
Old 03-20-2011, 11:23 AM   #4
Newb
 
Join Date: Mar 2011
Posts: 7
act like runniong rich

no smoke, cleaned out the throttle body good as for code the auto part stores here say they can only read 96 and up havent taken to shop yet. did look for service engine light but there is no socket or bulb. whats a stuck valve ack like?
osucowpoke is offline   Quote Quick Reply
Old 03-20-2011, 11:28 AM   #5
Jeeper

WF Supporting Member
 
99jeeper's Avatar
 
Join Date: Feb 2011
Location: nothern michigan
Posts: 449
Images: 3
i think that you can get the codes out by doing the key on-off-on thing . have to count the flash's.
__________________
99jeeper is offline   Quote Quick Reply
Old 03-21-2011, 01:35 PM   #6
Jeeper
 
Join Date: Feb 2011
Location: fredericksburg,va
Posts: 19
sounds like it could be the choke if it has one.mine did the same thing and it ended up being the electronic choke was bad .i replaced it with a manuel choke now it runs fine
74 sporster is offline   Quote Quick Reply
Old 03-21-2011, 04:04 PM   #7
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Have you checked the fuel pressure regulator?
What do the plugs look like, black and sooty?
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 03-23-2011, 09:05 AM   #8
Newb
 
Join Date: Mar 2011
Posts: 7
Plugs look good. Just found the service engine light seems to be throwing out 2 codes 1 for the crankshaft sensor and the map sensor i thing the crankshaft one should be first from what i read it has something to do with the fireing of the cylider any suggestions? what does the map sensor do?
osucowpoke is offline   Quote Quick Reply
Old 03-23-2011, 12:05 PM   #9
Jeeper
 
Tyewilly's Avatar
 
Join Date: Dec 2010
Posts: 551
Map is the manifold absolute pressure sensor, it reads the manifold vacuum that the computer uses to determine engine load and thus how much fuel to give the motor. It's located on the firewall top center. Kind of a flat black plastic thing with an electrical connector and a vacuum line running to it. Check the vacuum line going to it before you replace it, the stock lines are plastic and break, crack, and chafe over time.
Other than that, it may be a clogged catalytic converter choking your motor.
Tyewilly is offline   Quote Quick Reply
Old 03-27-2011, 10:11 AM   #10
Newb
 
Join Date: Mar 2011
Posts: 1
Frustrated

I have been haveing the same problem. Jeep will run for 15- 30 min and act as if the fuel stoped. Lean condition and backfireing. If I hold the gas pedal to the floor it will rev up to 4k rpm and act as if the fuel shut off and drop to 2k rpm then act as if it is getting gas going back up to 4k again. It will repeat this cycle if i hold the pedal to the floor. Same as most of the other posts only seems to do it after it runs for a bit. I will note one thing though. It is happening after the engine has warmed up. I have never had it do it on a cold start. Starts right up and runs fine except on a WOT situation.
morse45411 is offline   Quote Quick Reply
Old 03-27-2011, 03:47 PM   #11
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Quote:
Originally Posted by morse45411 View Post
I have been haveing the same problem. Jeep will run for 15- 30 min and act as if the fuel stoped. Lean condition and backfireing. If I hold the gas pedal to the floor it will rev up to 4k rpm and act as if the fuel shut off and drop to 2k rpm then act as if it is getting gas going back up to 4k again. It will repeat this cycle if i hold the pedal to the floor. Same as most of the other posts only seems to do it after it runs for a bit. I will note one thing though. It is happening after the engine has warmed up. I have never had it do it on a cold start. Starts right up and runs fine except on a WOT situation.
Have you checked for codes?If it runs fine when cold it could be the air temp sensor in the manifold.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 07-05-2011, 09:06 AM   #12
Newb
 
Join Date: Mar 2011
Posts: 7
changed orings in the fuel injector rail thats where one of the leaks were and the plugs still running strong!

osucowpoke is offline   Quote Quick Reply
Reply

Tags
flooding , help! , missing , stuttering

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie here looking for insight on buying a used WRANGLER mestude JK General Discussion Forum 12 01-18-2011 02:09 PM
Daystar's new JK Hood Wrangler 1BLKJP JK General Discussion Forum 10 06-20-2008 09:26 AM
2008 Wrangler Purchase soupy1957 JK Pics Forum 23 11-22-2007 04:48 AM
First Wrangler - 3rd Jeep!!! tritonman WF New Member Check In 10 09-28-2007 08:27 AM
Wrangler X or Wrangler Saraha? battleb WF New Member Check In 9 04-21-2007 06:46 PM



» Featured Product

All times are GMT -5. The time now is 05:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC