94 yj bogging down/sputtering/high fuel press.?? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-13-2012, 03:32 AM   #1
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
94 yj bogging down/sputtering/high fuel press.??

So when my 4 banger gets warm and I'm driving around town I'm having an issue with my idle, it will idle about 800 them drop to about 3-400 then back to 800 and keep fluctuating like its going to stall but it won't. It will also act like its going to bog down when I'm driving and hit the gas it feels like it hits an RPM rev limiter, and I get a loud popping/backfire kinda sound from the engine compartment, any ideas?? Iv replaced everything and I'm running out of ideas! I haven't done a compression check though, could it be a clogged exhaust system? I also have a fuel pressure of 55 psi at the rail with the vacuum tube on or off

This is what Iv replaced - TPS,IAC,Fuel filter, fuel regulator,cleaned injectors, oil change "came out normal" , air filter and cleaned my throttle body and new vacuum hose on fuel regulator and case vent.

I know my muffler is bad due to the chunks rattling around and I think my cat might be bad too?

cautiocones is offline   Quote
Old 09-13-2012, 06:48 AM   #2
Jeeper
 
Pullsout's Avatar
 
Join Date: Jul 2010
Posts: 288
After all the other stuff you've replaced I would think that the exhaust is going to be your only other option. If exhaust can't get out you're gonna have a bad time.

__________________
always a new project.
Pullsout is offline   Quote
Old 09-13-2012, 09:33 AM   #3
Jeeper
 
Tyewilly's Avatar
 
Join Date: Dec 2010
Posts: 551
Check the vacuum line to the map sensor, the factory plastic vacuum lines have a tendency to get holes rubbed in them from years of vibration.
Tyewilly is offline   Quote
Old 09-13-2012, 10:59 AM   #4
Jeeper
 
jfbilbro's Avatar
 
Join Date: Jul 2011
Location: Central Alabama
Posts: 780
It could also be the crank position sensor, but a clogged cat will do that too....
__________________
...huh?...
jfbilbro is offline   Quote
Old 09-17-2012, 06:46 PM   #5
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
Well I feel stupid, wound up being a loose distributer shaft, had about an 1/8th of an inch of play when shaking it around -_-
cautiocones is offline   Quote
Old 09-23-2012, 04:55 PM   #6
Jeeper
 
Pullsout's Avatar
 
Join Date: Jul 2010
Posts: 288
it's always the littlest things that get you
__________________
always a new project.
Pullsout is offline   Quote
Old 05-17-2013, 01:10 AM   #7
Jeeper
 
Join Date: Dec 2011
Posts: 29
Quote:
Originally Posted by cautiocones View Post
Well I feel stupid, wound up being a loose distributer shaft, had about an 1/8th of an inch of play when shaking it around -_-
I have identical symptoms with my 2.5 right now. I really hope this is my problem and plan on checking it out tomorrow. I will post results.
__________________
'92 YJ, 2.5L, SYE Kit, 33" Tires, 4" Lift, 4:10 gears, D30 locked and D35 open.
matrix311 is offline   Quote
Old 05-17-2013, 06:59 AM   #8
Jeeper
 
voyager_1700's Avatar
 
Join Date: Dec 2011
Posts: 343
Hey.. I just ran into a similar issue.. My 93 6cyl idle would surge.. then settle back down.
I got a code 51 (O2 sensor reporting lean condition). She was running rough on the way home.. I was poking around and noticed the back 3 fuel injectors were loose.. Then the magic Check Engine light came on and now I was getting Code 27 (Fuel Injector Control) as well as poor fuel economy about 10mpg
It turned out The fuel return line was crimped restricting flow back to the tank causing high fuel pressure (My mech told me 90 pounds) Causing a rich condition fouling out my plugs and o2 sensor was toast. Just got it back last night no surge and running great..

voyager_1700 is offline   Quote
Reply

Tags
air , bog , fuel , sputter

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:29 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC