94 yj has been running hot - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-05-2010, 06:48 PM   #1
Jeeper
 
Join Date: Dec 2009
Location: Conroe, TX
Posts: 477
94 yj has been running hot

lately ive noticed that my yj has been running alittle hotter than normal and it has been over heating while im sitting at ideal and randomly while driving down the highway.

i checked the fan and it feels fine. ive been paying attention to the temp and i can see when the thermostat opens. and theres no leaks.

so im thinking that its probably just the radiator is old and needs to be replace. but i dont want to go and blow 160 if thats not what it is.

any input?

thechink09 is offline   Quote
Old 07-05-2010, 06:51 PM   #2
Jeeper
 
csamn2007's Avatar
 
Join Date: Aug 2009
Location: Peterson AFB CO
Posts: 1,911
Send a message via AIM to csamn2007
I would change the thermostat, cheaper than a rad. I had a similar problem on an old car, replaced the thermostat fixed it.

__________________
2000 Wrangler Sport
2 in Procomp SL 1 in BL
33 in Procomp MTs
csamn2007 is offline   Quote
Old 07-05-2010, 08:30 PM   #3
Jeeper
 
mikeyford3's Avatar
 
Join Date: May 2010
Location: Millville, south jersey
Posts: 135
Dont rule out a blown head gasket Could be do you smell anti freeze. Do you have white smoke coming out of your exaust?
Check your oil and anti freeze. If theres thick white milky substance in your oil most likely blown head gasket.
I would say check your thermostat first. if you take it out, try to move it manually if its stuck and doesnt move easily theres your problem.
How bad did it over heat you could of even blew a head gasket then when you had it over heat at a really high temp over and over again.
mikeyford3 is offline   Quote
Old 07-05-2010, 08:41 PM   #4
Jeeper
 
Join Date: Dec 2009
Location: Conroe, TX
Posts: 477
im going to change my oil in about a week so ill check it then.

and it got up to 240ish when it over heated while sitting. and it gets a little past 220 sometimes while on the highway, its only gotten hot on the highway twice
thechink09 is offline   Quote
Old 07-05-2010, 10:14 PM   #5
Jeeper
 
TJ Terry's Avatar
 
Join Date: Jun 2010
Location: Minnesota
Posts: 135
If it over heats more with it idleing I would suspect rad. pluged with bugs, try to see if you can put a trouble light on one side of the rad. and look through the other side and see light through it. If rad was pluged inside it would overheat quicker driving down the road. The best way i have found to see if head gasket is blown is to remove the thermostat, remove the water pump belt. fill the cooling system as full as you can with stat removed and housing installed. start the eng and look for bubbles in where the stat should be. You will get a few bubbles at first due to trapped air pockets but if it looks like you are blowing into a straw in a glass of water you have a problem. If it all looks good then put a new stat in when you put it back together.
TJ Terry is offline   Quote
Old 07-05-2010, 11:58 PM   #6
Jeeper
 
Join Date: Mar 2010
Location: Buffalo Grove, IL.
Posts: 248
Don't rule out a faulty temp sensor. The temp gauge has it's own sensor on the back of the head. It could also be your water pump not circulating enough coolant.
Snuffy115 is offline   Quote
Old 07-06-2010, 08:06 AM   #7
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 10,475
Images: 5
I would drain and refill the system.. see if that helps, also cheap solution and easy. Any movement front to back with the fan(when off) that will usually mean water pump is going.

__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 12:00 PM
Running boards or no running boards harrington JK General Discussion Forum 13 11-18-2009 02:36 PM
RBNM's Running Adventures RatherBNarizona Off-Topic 8 09-24-2009 02:25 PM
'94 YJ 2.5L Running Like Poo... Tony YJ Tech Forum 4 10-22-2008 01:13 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC