94yj crazy 4wd problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-29-2013, 10:46 PM   #1
Jeeper
 
Join Date: Dec 2012
Location: Pittsburgh, Pa
Posts: 34
94yj crazy 4wd problem

So I went to put my yj in 4wd the other day and it went in no problem. As soon as I started moving it popped out and back into 2wd. I thought maybe it wasn't in all the way so I made sure it was in and held it in place and 4wd was fine, as soon as I let it go it popped out again. So I put it in 4Lo to see what would happen and it also popped all the way back to 2wd. Has anyone heard of this issue or dealt with it before? I'm leaning towards the vacuum motor being bad but everyone ive talked to has never heard of a problem like this. Any help appreciated

JeepGuy61 is offline   Quote Quick Reply
Old 03-29-2013, 10:50 PM   #2
Jeeper
 
bigtoysforbigboys's Avatar
 
Join Date: Mar 2013
Posts: 252
If im not mistaken the vacuum setup should only lock in the from axle ...sound more like a tc problem to me

bigtoysforbigboys is offline   Quote Quick Reply
Old 03-30-2013, 12:22 AM   #3
Jeeper
 
Join Date: Dec 2012
Location: Pittsburgh, Pa
Posts: 34
Your right on it only locking in the fronts axle its just from everything I found it sounds like vacuum. It could be a tc problem I'm just praying it isn't. I just lost my job and don't have money to replace the tc at the moment
JeepGuy61 is offline   Quote Quick Reply
Old 03-30-2013, 12:29 AM   #4
Jeeper
 
bigtoysforbigboys's Avatar
 
Join Date: Mar 2013
Posts: 252
Sounds to me like the tc isn't engaging all the way....might be an adjustment for that
bigtoysforbigboys is offline   Quote Quick Reply
Old 03-30-2013, 01:18 AM   #5
Jeeper
 
Join Date: Dec 2012
Location: Pittsburgh, Pa
Posts: 34
I'm gonna look for something like that I hope its an adjustment or even a linkage
JeepGuy61 is offline   Quote Quick Reply
Reply

Tags
4wd , 4wd doesnt work , help needed , yj.

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:19 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC