95 2.5 wont run then runs then wont run..... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-04-2009, 09:15 PM   #1
Newb
 
Join Date: Jan 2009
Posts: 7
95 2.5 wont run then runs then wont run.....

95 2.5 yj runs fine when it starts but every once in a while it wont start.... it cranks fine but wont fire. when this happens there is no spark out of the coil.. bu then out of nowhere it will just start. im pretty sure its just a loose wire or bad ground or something but im not sure where i would look to check it out. crank sensor wire? whats the deal with auto shutdown..... i need help

polarisprox2 is offline   Quote Quick Reply
Old 03-04-2009, 11:30 PM   #2
Jeeper
 
NAVYCHIEF's Avatar
 
Join Date: Sep 2008
Posts: 2,207
try the ecu. check the connections and clean all the pins on the connector. later dude.

NAVYCHIEF is offline   Quote Quick Reply
Old 03-05-2009, 09:12 AM   #3
Jeeper
 
Join Date: Jan 2009
Location: scranton, pennsyltucky
Posts: 43
My guess would be the main harness plug on the fire wall. I've seen terminals get corroded or melt to where they don't get a connection. Best thing to do is take it apart clean the terminals, check for loose terminals, and reinstall with di-electric grease. Good luck keep us posted.
jeepster213 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
POKER RUNS IN 08 or GLAMIS??? 6DEVIL16 General Jeep Discussion 1 12-28-2007 11:01 AM
Runs rough after mudding, winch dead LIVE TO JEEP,JEEP TO LIVE TJ Tech Forum 8 12-03-2007 07:21 PM
an odd idle but runs fine when driving. hemmer TJ Tech Forum 16 08-29-2007 10:22 PM
starts and runs wide open bluegrass107 YJ Tech Forum 9 06-07-2007 07:01 PM
4 cylinder Engine Icon Goes then runs BAD! Bassplunker TJ Tech Forum 11 05-24-2007 09:12 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:46 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC