95 Jeep Wrangler 4.0L, Chugs On Acceleration and back fires sometimes - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-10-2011, 04:46 PM   #1
Newb
 
Join Date: Sep 2011
Posts: 3
Question 95 Jeep Wrangler 4.0L, Chugs On Acceleration and back fires sometimes

I have a 95 Wrangler 4.0 It starts and idles fine, however after driving it starts sputtering like it is not getting fuel. This only happens when driving if stopped and idling it runs fine. The problem is not constant and only seems to be happening after diving a short while, after 10 to 15 miles, and seams to do it more in the mornings when itís cooler out temps in the mid 60ís, never seams to do it on the way home in the evening. I can clutch it rev it up and to about 3 grand and it will pop and back fire for a few seconds and then start running fine again for a few miles. This always happens after riding at a constant speed. What I have replaced; Plugs are less then two years old and are Bosch Platinum Plus, in the last few days Iíve replaced, the Plug Wires, Cap & Rotor, and then the coil. And Iím still chasing my tail. Can you help? What am I missing????

Kcrowell is offline   Quote Quick Reply
Old 09-10-2011, 05:26 PM   #2
2xs
Cali Smog Nazi.

WF Supporting Member
 
2xs's Avatar
 
Join Date: Jun 2011
Location: Santa Rosa, Ca.
Posts: 2,627
Images: 3
Quote:
Originally Posted by Kcrowell View Post
.... Plugs are less then two years old and are Bosch Platinum Plus,....
You can start by installing OE type spark plugs, then get back to us.

2xs is offline   Quote Quick Reply
Old 09-11-2011, 07:29 AM   #3
Newb
 
Join Date: Sep 2011
Posts: 3
No help here

Well the plugs came from my local parts store, I give them the make and model of my Jeep and they had about ten different makes of plugs I could have got and all of them where OM replacement plugs, so I picked Bosch. And like I said they have been running find for about two years. I have pulled the plugs and checked them, and all looked find. It looks like this Forum is not going to be any help for me I guess I will look somewhere eles.
Kcrowell is offline   Quote Quick Reply
Old 09-11-2011, 08:47 AM   #4
Jeeper
 
banks316's Avatar
 
Join Date: Apr 2011
Location: Longview, WA
Posts: 2,089
First off bosch plugs arnt the problem I run the platinum 4s. Start with checking the tps, vaccum lines, air step thing its the other plug on the throttle body.
__________________
93 YJ I6 5spd
My YJ Build +1.5 inch SOA ,37 12.50 15R Swamper M16's, 5.22:1/2.97:1 Stak Tcase with 92 Crawl Ratio--------SOLD...
banks316 is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Jeep Wrangler 4.0L Chugs On Acceleration Kcrowell JK General Discussion Forum 2 09-10-2011 01:09 PM
A little something about the Wave. Put the word Wrangler where needed. Wally Meyers General Jeep Discussion 5 10-05-2010 02:47 PM
2000 jeep wrangler fuel pump replacement madmilitia TJ Tech Forum 16 07-08-2010 03:40 PM
Jeep Wrangler Problem- Need Input cfauver TJ Tech Forum 3 11-05-2008 07:03 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:27 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC