95 Jeep Wrangler problem when running - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-21-2009, 09:42 AM   #1
Newb
 
Join Date: Dec 2009
Posts: 4
95 Jeep Wrangler problem when running

Hello all,

My name is Josh. I recently purchased a 1995 Jeep Wrangler. I love the thing to death, but no one I know can figure out a problem I'm having with it. It will start up fine, and run great for a while, but after you start driving down the highway for a little bit it will start sputtering horribly, decelerating even though my foot is still on the gas, and backfiring really bad. After about a minute of this, it will straighten out and run fine for a while, but it happens often. I have taken it to two mechanics and it still isn't fixed. One of them tried to access the computer, and it wouldn't talk to their diagnostics tool, I have a feeling this may some how be connected to the problem, but I don't know. Any help is appreciated, thanks in advance.

-Josh

Jeep_Lynch is offline   Quote Quick Reply
Old 12-21-2009, 09:51 AM   #2
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 9,796
Images: 5
welcome to the forum. Give us a bit more information, which engine do you have? Also did you take it to a Jeep dealer or just to general shop mechanics?

__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote Quick Reply
Old 12-21-2009, 10:21 AM   #3
Newb
 
Join Date: Dec 2009
Posts: 4
Thanks for the welcome. It has a 2.5L, 4 Cyl. engine. I took it to two friends of my fathers who are general shop mechanics in hope that they could find the problem so I wouldn't have to shove out the big bucks for the dealership just to look at it, let alone fix it. Thats not to say I wont take it there, in fact I'm close to doing that. I just don't have the money yet...
Jeep_Lynch is offline   Quote Quick Reply
Old 12-21-2009, 10:29 AM   #4
Jeeper
 
Join Date: Sep 2009
Location: quinc,il
Posts: 395
Does it have an iac motor, IM betting it does and that could be the problem!
__________________
92 wrangler yj 4 in lift, sye, posi lock, 35x12.50x15 on outlaw rims. much more to do!!
jeepers92 is offline   Quote Quick Reply
Old 12-21-2009, 12:45 PM   #5
Newb
 
Join Date: Dec 2009
Posts: 4
I'm sure it does, but would that cause the problem I described? It happens as I'm actually driving.
Jeep_Lynch is offline   Quote Quick Reply
Old 12-21-2009, 01:03 PM   #6
Jeeper
 
Join Date: Sep 2009
Location: quinc,il
Posts: 395
yes, I believe, it controlls fuel and air. which can cause sputtering and backfiring! I would ask a mechanic, As I am certainly not! but might be worth a look
__________________
92 wrangler yj 4 in lift, sye, posi lock, 35x12.50x15 on outlaw rims. much more to do!!
jeepers92 is offline   Quote Quick Reply
Old 12-21-2009, 01:13 PM   #7
Newb
 
Join Date: Dec 2009
Posts: 4
Hmmm, any thing is worth a try I suppose. Oh, btw to anyone responding to this post, I was able to pull the DTC's from the On/Off/On/Off/On sequence and got the 52** error code, (Oxygen sensor signal input indicates rich air/fuel ratio condition during engine operation.). Don't know if this helps.....

Jeep_Lynch is offline   Quote Quick Reply
Reply

Tags
backfiring , computer , engine , jeep , sputtering

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'97 Wrangler Cold Idle / Load Flooding Problem brad07x TJ Tech Forum 1 12-18-2009 11:10 PM
1987 Jeep Wrangler Running Issues dj69firebird69 YJ Tech Forum 10 05-17-2009 08:01 AM
2007 Jeep Wrangler Unlimited review torres JK General Discussion Forum 5 05-22-2007 04:12 PM
2006 jeep wrangler tj gfa WF New Member Check In 11 04-04-2007 10:15 PM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC