'95 Odometer Stopped Working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-11-2010, 08:28 AM   #1
Newb
 
drum03's Avatar
 
Join Date: Aug 2008
Location: Clinton, IA
Posts: 6
'95 Odometer Stopped Working

The odometer stopped working on my '95 YJ. All the other gages still work (including the spedo). Any thoughts as to what could have caused this issue?

The only explanation I can come up with stems from media blasting the drivers side floor board last fall. After blasting the floor there was media dropping from under the dash for about a month. I finally took the dash apart, removed the gage cluster and blew out the remaining media with an air hose. The odometer stopped working about two months after this. Could the media have worked its way into the cluster and bound up the odometer gears?

Any input will be greatly appreciated!

Robby

drum03 is offline   Quote Quick Reply
Old 05-14-2010, 07:09 AM   #2
Newb
 
drum03's Avatar
 
Join Date: Aug 2008
Location: Clinton, IA
Posts: 6
Has anyone else had this problem? I plan on working on my Jeep tomorrow and would like a few ideas that I can troubleshoot.

The only other possible cause that I found while searching was a bad connection between the gage cluster and wiring harness.

drum03 is offline   Quote Quick Reply
Old 05-14-2010, 10:21 PM   #3
Jeeper
 
Kohrs93's Avatar
 
Join Date: Apr 2010
Location: Moline, IL
Posts: 594
A fuse? I know my friend had the same problem with his gas gage and a 10 cent fuse fixed the problem.
__________________
92 2.5L 5 speed - 3" RC lift - Skyjacker Steering Stabilizer - 17" XD HOSS wheels - 315/70r17 BFG All-terrain T/A
Kohrs93 is offline   Quote Quick Reply
Old 05-19-2010, 07:18 AM   #4
Newb
 
drum03's Avatar
 
Join Date: Aug 2008
Location: Clinton, IA
Posts: 6
I checked the fuse for the gage cluster last night. It was still in tact. Is there an individual fuse for each gage that I'm missing?
drum03 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower fan has stopped working? J.A TJ Tech Forum 6 01-17-2010 07:19 AM
Gas gauge stopped working today...HELP! rcwood87 YJ Tech Forum 3 11-08-2009 04:08 PM
Cigar lighter stopped working Gerald TJ General Discussion Forum 0 07-13-2009 11:25 AM
Compass/Temp rear view mirror stopped working? Rudds General Jeep Discussion 0 03-13-2009 08:41 AM
engine light stopped working mrbigjeep TJ Tech Forum 8 09-22-2006 10:38 PM



» Featured Product

All times are GMT -5. The time now is 04:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC