95 wrangler yj engine issues 2.5 liter - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-23-2013, 12:20 PM   #1
Newb
 
Join Date: Feb 2013
Posts: 14
95 wrangler yj engine issues 2.5 liter

The problem is that it sounds like the timing is out on it when i turn it on. it will run ok and miss a little run semi smooth. i rev it and the engine light comes on and it stalls. restart, then it loads up and it start to flood with gas then backfires loudly 3-4 times sounds like a john deere 60 tractor when you gas it, then it will quit. try to restart and it vaporlocks unless i take out the f/p relay, then it starts then dies and backfires. 2.5 liter auto trans 95 wrangler is what i am serviceing. i know it has good fuel presure, new fuel pump, 35PSI then 40 psi when you remove the vacumm to the fuel regulator with the few mins i had it running i checked the fuel presure. spark is ok also. compression is 150psi 1-3 cyl then 160psi on the 4th cyl. I have replaced the timing chain, timed it according to the haynes manual. distributor was installed according to the haynes manual, 10 o clock on the oil pump gear and putting that pin to keep the rotor still. The entire ignition system has been gone through... all the sensors related to the ignition system, crank positon sensor, coil pickup, COIL its self, and cap/rotor / spark plugs have been replaced. I am wondering what the heck is wrong with my jeep that it won;t run! check engine light comes on then goes off when you get it started. i haven't pulled codes yet.

xpdude is offline   Quote
Old 02-23-2013, 12:24 PM   #2
Newb
 
Join Date: Feb 2013
Posts: 14
also... if i just idle it say from letting it sit after taking out sparkplugs and lighting all the gas in the cylinders with a stick lighter, it will run semi ok and sputter and miss a bit. for 3-5 mins then two cyl cut out then it floods and dies out.

xpdude is offline   Quote
Old 02-23-2013, 12:26 PM   #3
Newb
 
Join Date: Feb 2013
Posts: 14
i want to go jeeping with this thing! lol its annoying, like a money pit/
xpdude is offline   Quote
Old 02-23-2013, 07:22 PM   #4
Jeeper
 
Join Date: Mar 2011
Location: Derry PA
Posts: 415
check to make sure the cat isnt plugged up
__________________
1995 wrangler 4 cyl 5 1" poly body lift,2.5 ome 3/4" shackle, 32" swampers lock right in the d-30
1.25 motor mount lift full cage hi line fendered
98 TJ 2.5 5 speed 2.5 rc lift 1" poly body lift rancho 5000s
SCOOPYS-YJ is offline   Quote
Old 02-26-2013, 07:54 PM   #5
Newb
 
Join Date: Feb 2013
Posts: 14
i have verified the cat is ok. the exaust leaks at the manifold so it should run... has good fuel and spark.. checked the codes, had a 12, 33, 41, had code 27 also.
xpdude is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:06 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC