95 yj ac help please - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-05-2011, 03:39 PM   #1
Jeeper
 
Join Date: Apr 2011
Posts: 154
95 yj ac help please

Ok so my AC may have been added on aftermarket, its a 2.5 95 yj. I think its aftermarket cuz in the fuse box thier is no relay in the AC location and its not set up so you can put a relay in the AC location cuz thier is no prongs for it to slide into... my AC works great its just that my idle doesn't kick up when i turn it on. My rpms will drop to like 500 and its really rough. So my question is ... is thier supposed to be a wire ran into the ecm or a connector somewhere that did not get connected? I know my iac is working fine, so i camcled that out of the equasion. My other question is what is the random wires inside the engine bay kinds by the battery for? They are wired for a relay to be plugged into them but thiers no relay in it? I can tell its wired from the factory, it's just chillin on the firewall hanging thier kinda directly in the center

Csechols38 is offline   Quote Quick Reply
Old 08-05-2011, 03:42 PM   #2
Jeeper
 
Join Date: Nov 2009
Location: North Carolina
Posts: 705
Oh wait, we have AC in our 95 YJs?? hahaha

__________________
Cheers - Andrea (& Greg!)
---
'95 YJ Rio Grande / 5 spd
'08 JKU / 6 spd
andreafahy01 is offline   Quote Quick Reply
Old 08-06-2011, 02:20 AM   #3
Newb
 
mikeywrangler's Avatar
 
Join Date: Jul 2011
Posts: 14
Quote:
Originally Posted by andreafahy View Post
Oh wait, we have AC in our 95 YJs?? hahaha
atleast not rio's lol! wish i got mine to work though
mikeywrangler is offline   Quote Quick Reply
Old 08-06-2011, 11:13 AM   #4
Jeeper
 
Join Date: Nov 2009
Location: North Carolina
Posts: 705
Quote:
Originally Posted by mikeywrangler View Post
atleast not rio's lol! wish i got mine to work though
hehehehe. I ride with my doors and top off spring till winter so I'd never even be able to feel the AC if it did work. Actually, for all I know it may work...
__________________
Cheers - Andrea (& Greg!)
---
'95 YJ Rio Grande / 5 spd
'08 JKU / 6 spd
andreafahy01 is offline   Quote Quick Reply
Old 08-06-2011, 12:58 PM   #5
Jeeper
 
Join Date: Apr 2011
Posts: 154
anyone have some usefull info? i live in arizona and its 110 outside no doors and top off doesnt help much
Csechols38 is offline   Quote Quick Reply
Old 08-06-2011, 01:00 PM   #6
Jeeper
 
Join Date: Nov 2009
Location: North Carolina
Posts: 705
Nope sorry, no useful info here in NC where it's only 105 degrees.
__________________
Cheers - Andrea (& Greg!)
---
'95 YJ Rio Grande / 5 spd
'08 JKU / 6 spd
andreafahy01 is offline   Quote Quick Reply
Old 08-06-2011, 01:15 PM   #7
Jeeper
 
Join Date: Aug 2011
Location: Viola,Idaho
Posts: 60
I hope someone can chime in to help you Csechols. I would like glean some good info from some of the folks in this forum that have a clue about AC.
88muddog is offline   Quote Quick Reply
Old 08-06-2011, 01:32 PM   #8
Jeeper
 
Join Date: Nov 2009
Location: North Carolina
Posts: 705
I'm sure someone will soon, there are so many members here with such a wealth of knowledge! good luck to ya, I hope you find some relief soon!
__________________
Cheers - Andrea (& Greg!)
---
'95 YJ Rio Grande / 5 spd
'08 JKU / 6 spd
andreafahy01 is offline   Quote Quick Reply
Old 08-24-2014, 01:37 PM   #9
Newb
 
Join Date: Aug 2014
Posts: 1
Quote:
Originally Posted by Csechols38 View Post
Ok so my AC may have been added on aftermarket, its a 2.5 95 yj. I think its aftermarket cuz in the fuse box thier is no relay in the AC location and its not set up so you can put a relay in the AC location cuz thier is no prongs for it to slide into... my AC works great its just that my idle doesn't kick up when i turn it on. My rpms will drop to like 500 and its really rough. So my question is ... is thier supposed to be a wire ran into the ecm or a connector somewhere that did not get connected? I know my iac is working fine, so i camcled that out of the equasion. My other question is what is the random wires inside the engine bay kinds by the battery for? They are wired for a relay to be plugged into them but thiers no relay in it? I can tell its wired from the factory, it's just chillin on the firewall hanging thier kinda directly in the center
Csechols38, I'm having the same problem. How did you fix it

GatorPA is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:19 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC