95 YJ Fuel Pump, no power at connector? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-16-2007, 02:39 PM   #1
Join Date: Apr 2007
Posts: 10
95 YJ Fuel Pump, no power at connector?

I have a 1995 Jeep Wrangler with a 2.5 4 cylinder, fuel injected.

The fuel pump isn't working. No 12VDC at the connector going to the pump.

My gas gauge is working, but the fuel pump isn't pumping. When I connect an external 12 VDC to the fuel pump, I can hear the pump working, get fuel pressure at the injector rail and the Jeep starts.

I traced the the wire ,Green with Black stripe (GRN/BLK), from the fuel tankback to the power distribution center.

All my fuses and relays look and appear fine. Any ideas?

Thanks, Steve.

snb73 is offline   Quote
Old 10-15-2008, 11:44 AM   #2
Join Date: Nov 2006
Posts: 12
What did you figure out? I have same problem

captflyte is offline   Quote
Old 10-15-2008, 01:09 PM   #3
chezuki's Avatar
Join Date: May 2007
Location: Anywhere I roam
Posts: 830
lol, almost exactly 1 year old...
Are you born to resist, or be abused?

chezuki is offline   Quote
Old 10-15-2008, 01:18 PM   #4
yjwrangler's Avatar
Join Date: Mar 2008
Location: your house if we hit it off good
Posts: 1,497
Send a message via AIM to yjwrangler
^boooooooooooooooooooooooooooooooooooooooooooooooo ooooooo

i hope you like high taxes and socialized medicare...anyways have a good day!!!!!!!!!!!!
" Crocs have the rare combination of being expensive, poor quality, and ugly. It's quite a feat for one shoe to suck this bad." -some bad a$$
yjwrangler is offline   Quote
Old 06-06-2013, 12:46 PM   #5
The Silver Gorilla's Avatar
Join Date: Jan 2013
Location: Tampa
Posts: 641
^^same issue
The Silver Gorilla is offline   Quote
Old 06-06-2013, 02:31 PM   #6
indirocz28's Avatar
Join Date: Feb 2013
Location: Fort Hood/ BCS, TX
Posts: 1,070
Did you follow the wire back up front to be sure you don't have a break in it somewhere? Checked the Fuel Pump Relay?

If you need a wiring diagram, PM me.
MY1990 "Little YJ" Build: http://www.wranglerforum.com/f8/brou...ay-242064.html
Come wheel with us at Brazos Valley Off Road Ranch! http://www.wranglerforum.com/f53/bra...tx-237657.html
indirocz28 is offline   Quote
Old 06-06-2013, 03:02 PM   #7
The Silver Gorilla's Avatar
Join Date: Jan 2013
Location: Tampa
Posts: 641
Replaced the relay, and followed the wires back as well as i know how (this is my first time dealing with something like this).

The Silver Gorilla is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrangler fuel pump not running on start captflyte YJ Tech Forum 2 05-09-2009 09:39 PM
YJ Electric fuel pump experience needed fgcox1 YJ Tech Forum 2 07-09-2008 07:29 PM
Fuel Pump? jjonesx2 YJ Tech Forum 5 01-22-2008 08:32 AM
95 2.5 fuel pump cuts off ml68nova YJ Tech Forum 0 08-09-2007 06:04 PM
No power to my fuel system? the idiot magnet YJ Tech Forum 3 03-18-2007 04:27 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:45 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC