95 yj headlight problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-11-2010, 06:55 PM   #1
Newb
 
Join Date: Sep 2010
Posts: 11
95 yj headlight problems

when i turn on my brights after about ten minutes or so they go out and i have no headlights, high or low beams but they come back on after a few minutes of hitting the high beam switch. last night they went out and wont come back on ( not good on a middle ga back road at night). The HB indicator light does not even come on. Any ideas on what the cause? all the fuses are good.

igglysnaggly is offline   Quote Quick Reply
Old 09-11-2010, 08:59 PM   #2
Jeeper
 
Join Date: May 2010
Posts: 341
you should check all the wires and make sure they are not corroded. just to rule it out.

JDGROVER is offline   Quote Quick Reply
Old 09-11-2010, 10:49 PM   #3
Jeeper
 
FNjeep's Avatar
 
Join Date: Jul 2010
Location: Everett, WA
Posts: 266
Sounds like a bad alternator. The harsh conditions has probably killed your battery too.

You'll have to begin with the classic replace : Check Battery Cables, Check the Battery, Check the Alternator, then check the Starter.
FNjeep is offline   Quote Quick Reply
Old 09-11-2010, 10:55 PM   #4
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,259
First thing to check is the plugs on the back of the headlights for corrosion.
Ibuildembig is offline   Quote Quick Reply
Old 09-11-2010, 11:49 PM   #5
Jeeper
 
Userbrand's Avatar
 
Join Date: Sep 2010
Location: East Bay California
Posts: 23
Images: 4
I have a 92 yj that did the same thing. I haven't used my high beams for a while. A few months ago after replacing the head lights they stopped working all together. Had dash lights but no head lights. I replaced the head light switch and it seams to have corrected everything.

My suggestion is to replace the switch. Under 20 bucks and easy to do.
Userbrand is offline   Quote Quick Reply
Old 09-12-2010, 08:07 AM   #6
Jeeper
 
VHunter's Avatar
 
Join Date: Sep 2010
Posts: 116
Quote:
Originally Posted by Userbrand View Post
My suggestion is to replace the switch. Under 20 bucks and easy to do.
I second that. I had the same problem in a different vehicle, and replacing the headlight switch fixed it.
VHunter is offline   Quote Quick Reply
Old 09-12-2010, 08:10 AM   #7
Newb
 
Join Date: Sep 2010
Posts: 11
replace which switch, the one that turns it on and off or the one that switches it from high to low beam?
igglysnaggly is offline   Quote Quick Reply
Old 09-12-2010, 08:23 AM   #8
Jeeper
 
VHunter's Avatar
 
Join Date: Sep 2010
Posts: 116
The one that turns the headlights on and off.
VHunter is offline   Quote Quick Reply
Old 09-12-2010, 08:26 AM   #9
Newb
 
Join Date: Sep 2010
Posts: 11
even though it only happened when the highs are on? what about the switch under the dash that switches it.
igglysnaggly is offline   Quote Quick Reply
Old 09-12-2010, 08:27 AM   #10
Newb
 
Join Date: Sep 2010
Posts: 11
dont want to replace stuff i dont need to. isnt there a relay that could be bad?
igglysnaggly is offline   Quote Quick Reply
Old 09-12-2010, 08:37 AM   #11
Jeeper
 
VHunter's Avatar
 
Join Date: Sep 2010
Posts: 116
Depending on the type of switch you have, it is either $5.00 or $20.00. I don't know how to test them. Just when this happened to me, I replaced the switch and it fixed the problem. The reason I replaced the switch was because I new someone else with the same problem, and it fixed their problem.

Check this thread.

http://www.wranglerforum.com/f8/head...ems-40875.html
VHunter is offline   Quote Quick Reply
Old 09-12-2010, 08:55 AM   #12
Newb
 
Join Date: Sep 2010
Posts: 11
Thanks for the help yall. guess ill start with the on off switch and go from there.always trust those that have fixed the same problem.
igglysnaggly is offline   Quote Quick Reply
Old 09-12-2010, 07:07 PM   #13
Newb
 
Join Date: Sep 2010
Posts: 11
thank you all. switch fixed it.
igglysnaggly is offline   Quote Quick Reply
Old 09-12-2010, 07:52 PM   #14
Jeeper
 
Userbrand's Avatar
 
Join Date: Sep 2010
Location: East Bay California
Posts: 23
Images: 4
Glad to hear.

Userbrand is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Sahara Headlight problems WTRoadrunner TJ Tech Forum 0 03-14-2010 02:50 PM
Headlight problems atlsouthpaw YJ Tech Forum 4 12-07-2009 05:54 PM
Round Headlight YJ ccain Builders Corner 13 05-25-2009 07:32 PM
Headlight Problems Sgt.Pepper22 TJ Tech Forum 23 01-30-2009 11:48 AM
Headlight Problems narcman07 YJ Tech Forum 1 10-28-2008 03:59 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:27 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC