95 YJ Speedometer Issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-22-2014, 03:35 PM   #1
Newb
 
Join Date: May 2012
Location: Nashville
Posts: 1
95 YJ Speedometer Issues

My 95 YJ sat for a couple of weeks in the cold and had to be jump-started. When it was started, the speedometer did not work. So far, I have replaced the VSS, confirmed continuity across the speedometer/tachometer ribbon cable, checked power at the VSS and at the back of the speedo assembly. The tach works fine, as do the lights, but no speedometer. I've spun the VSS with a drill and the needle never moves. I have confirmed 12vdc at the input to the VSS, as well as on the dark blue/white wire on the tach/speedo harness (pin 9 from left top row) and have 4.88vdc on the White/Orange wire from the VSS into the speedometer at the wiring harness (pin 3 top row from left).
Everything looks to be good, but no movement on the speedometer. Do I have a bad speedometer, or does the white/orange wire go somewhere in between the VSS and the dashboard harness that I should check? Is it possible to apply voltage directly to the speedo to test it on a bench?
I'm trying to get the speedo working so my soon-to-be 16-yo can drive it. Thoughts?

nosbig is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC