Auto transmission slipping and shifting really wierd... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-05-2010, 03:26 PM   #1
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,849
Auto transmission slipping and shifting really wierd...

Alright so my jeeps a 95 2.5l 3speed automatic with 3.73 gears and 30x9.5R15 tires. Its been acting up lately....no suprise there. But its to the point where i cant stand it anymore. When going from reverse to drive or drive to reverse its rpms dive down to 500 or below and sometimes will stall. I can start it right back up and go. It slips sometimes too mainly when its shifting from 1st to 2nd gear. Also it seems like it downshifts really really late. If im making a right hand turn And slow to 20mph as soon as i get back on the gas it shifts hard from 3rd to second then hard from 2nd to 1st. Then it shifts normally into 2nd but seems to shift into 3rd early. My brother who just completed drivetrains at wyotech (with a 94 overall average) said that i should change the fluid, filter and adjust the bands. I was wondering what you guys thought of this and how I'd go about adjusting the bands.

Thanks for your time, Ian.

__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote Quick Reply
Old 11-05-2010, 04:33 PM   #2
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,849
Bump da bump bump

__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote Quick Reply
Old 11-05-2010, 07:21 PM   #3
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,849
Anyone at all? Im kind of desperate to get this taken care of.
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote Quick Reply
Old 11-05-2010, 09:21 PM   #4
Jeeper
 
78j10's Avatar
 
Join Date: Feb 2010
Location: Lima,OH
Posts: 136
how many miles? might be time for a rebuild if the fluid change does not help
__________________
79 J20 360 4spd 4in lift : 03 F250 6.0 4x4 6spd 95k
78j10 is offline   Quote Quick Reply
Old 11-05-2010, 09:23 PM   #5
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,849
131000 and the fluid doesnt smell burnt or anything. Its light red in color.
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote Quick Reply
Old 11-05-2010, 09:31 PM   #6
Jeeper
 
78j10's Avatar
 
Join Date: Feb 2010
Location: Lima,OH
Posts: 136
the valve body could be pluged up with gunk adn that would cause the shift problems. My dodge had a .50 cent spring go bad and it would hang in second for ever then finally shift. try what you buddy said and see were that gets your. Also check your TV cable
__________________
79 J20 360 4spd 4in lift : 03 F250 6.0 4x4 6spd 95k
78j10 is offline   Quote Quick Reply
Old 11-05-2010, 09:39 PM   #7
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,849
If its something serious im just going to say screw it and run it in the ground i got a 350 and 700r4 almost ready to swap in
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote Quick Reply
Old 05-29-2013, 06:53 PM   #8
Newb
 
MatJnelson's Avatar
 
Join Date: May 2013
Location: wenatchee
Posts: 1
im having a similar problem only it sometimes doesn't shift into 3rd from 2nd, ive checked fluids all good
MatJnelson is offline   Quote Quick Reply
Old 05-29-2013, 10:40 PM   #9
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,071
Send a message via Yahoo to Nubby55
I'd say the o-rings on the servo's are hard and letting fluid by pass, but then again I'm not a mec-a-neck !just a good ol-boy that's been there.
pull it out an put a rebuild kit in it, sounds like all your hard parts are good.
Nubby55 is offline   Quote Quick Reply
Old 05-31-2013, 09:43 AM   #10
Jeeper
 
jfbilbro's Avatar
 
Join Date: Jul 2011
Location: Central Alabama
Posts: 746
The 3 speed autos have adjustable clutch bands....it's a fairly simple job if you have an inch/pound torque wrench. If not, take it to a shop.About 1 hour labor plus new filter, gasket and fluid..

__________________
...huh?...
jfbilbro is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shifting Into Four Wheel Drive And Transmission Question Allagash TJ General Discussion Forum 25 11-06-2012 07:23 PM



» Featured Product

All times are GMT -5. The time now is 03:33 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC