Auto transmission slipping and shifting really wierd... - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-05-2010, 03:26 PM   #1
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,851
yjkid95 is on a distinguished road
Auto transmission slipping and shifting really wierd...

Alright so my jeeps a 95 2.5l 3speed automatic with 3.73 gears and 30x9.5R15 tires. Its been acting up lately....no suprise there. But its to the point where i cant stand it anymore. When going from reverse to drive or drive to reverse its rpms dive down to 500 or below and sometimes will stall. I can start it right back up and go. It slips sometimes too mainly when its shifting from 1st to 2nd gear. Also it seems like it downshifts really really late. If im making a right hand turn And slow to 20mph as soon as i get back on the gas it shifts hard from 3rd to second then hard from 2nd to 1st. Then it shifts normally into 2nd but seems to shift into 3rd early. My brother who just completed drivetrains at wyotech (with a 94 overall average) said that i should change the fluid, filter and adjust the bands. I was wondering what you guys thought of this and how I'd go about adjusting the bands.

Thanks for your time, Ian.
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote
Old 11-05-2010, 04:33 PM   #2
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,851
yjkid95 is on a distinguished road
Bump da bump bump

__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote
Old 11-05-2010, 07:21 PM   #3
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,851
yjkid95 is on a distinguished road
Anyone at all? Im kind of desperate to get this taken care of.
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote
 
Old 11-05-2010, 09:21 PM   #4
Jeeper
 
78j10's Avatar
 
Join Date: Feb 2010
Location: Lima,OH
Posts: 141
78j10 is on a distinguished road
how many miles? might be time for a rebuild if the fluid change does not help
__________________
79 J20 360 4spd 4in lift : 03 F250 6.0 4x4 6spd 95k
78j10 is offline   Quote
Old 11-05-2010, 09:23 PM   #5
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,851
yjkid95 is on a distinguished road
131000 and the fluid doesnt smell burnt or anything. Its light red in color.
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote
Old 11-05-2010, 09:31 PM   #6
Jeeper
 
78j10's Avatar
 
Join Date: Feb 2010
Location: Lima,OH
Posts: 141
78j10 is on a distinguished road
the valve body could be pluged up with gunk adn that would cause the shift problems. My dodge had a .50 cent spring go bad and it would hang in second for ever then finally shift. try what you buddy said and see were that gets your. Also check your TV cable
__________________
79 J20 360 4spd 4in lift : 03 F250 6.0 4x4 6spd 95k
78j10 is offline   Quote
Old 11-05-2010, 09:39 PM   #7
Jeeper
 
yjkid95's Avatar
 
Join Date: Jan 2010
Location: Great Lakes, Illinios.
Posts: 1,851
yjkid95 is on a distinguished road
If its something serious im just going to say screw it and run it in the ground i got a 350 and 700r4 almost ready to swap in
__________________
My Build Thread... with plenty of pics
yjkid95 is offline   Quote
Old 05-29-2013, 06:53 PM   #8
Newb
 
MatJnelson's Avatar
 
Join Date: May 2013
Location: wenatchee
Posts: 1
MatJnelson is on a distinguished road
im having a similar problem only it sometimes doesn't shift into 3rd from 2nd, ive checked fluids all good
MatJnelson is offline   Quote
Old 05-29-2013, 10:40 PM   #9
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 3,467
Nubby55 is on a distinguished road
Send a message via Yahoo to Nubby55
I'd say the o-rings on the servo's are hard and letting fluid by pass, but then again I'm not a mec-a-neck !just a good ol-boy that's been there.
pull it out an put a rebuild kit in it, sounds like all your hard parts are good.
Nubby55 is offline   Quote
Old 05-31-2013, 09:43 AM   #10
Jeeper
 
jfbilbro's Avatar
 
Join Date: Jul 2011
Location: Central Alabama
Posts: 787
jfbilbro is on a distinguished road
The 3 speed autos have adjustable clutch bands....it's a fairly simple job if you have an inch/pound torque wrench. If not, take it to a shop.About 1 hour labor plus new filter, gasket and fluid..

__________________
...huh?...
jfbilbro is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shifting Into Four Wheel Drive And Transmission Question Allagash TJ General Discussion Forum 29 11-04-2014 11:59 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:39 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner