Blowing ignition coils. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-17-2010, 12:13 AM   #1
Jeeper
 
Join Date: Aug 2010
Posts: 33
Blowing ignition coils.

there's something about electrical stuff that my mind just doesn't process. But I'm a genius with mechanics. Too bad they go hand in hand these days-_-
ANYWAYS, I got a '89 YJ 2.5l that's been a project car. One day it wouldn't start again after moving it. No spark. I had just changed all the wires. So I changed the ICM, and the coil. When I put in the new coil, it started right up. But then when I went to start it again, no spark. I've been reading things about resistor wires and ballast resistors. I don't even know if this thing has one. I'm very stumped. I have a feeling it's going to be something stupid. But electrical problems for me is like chasing ghosts.

20PSI is offline   Quote Quick Reply
Old 09-17-2010, 02:32 AM   #2
Jeeper
 
mameyj's Avatar
 
Join Date: Aug 2009
Location: los angeles
Posts: 50
Check the (+) wire going to the coil if your getting 12v then you need a resistor wire or ballast resistor. my 87 yj had the same problem, I was getting 12v at idle, and about 14v if I'd rev it up. My coil would get really hot and then would just die. I installed a ballast resistor, and now the coil only gets about 9v, doesn't get hot anymore, and its been running great for about six months.

mameyj is offline   Quote Quick Reply
Old 09-17-2010, 09:02 PM   #3
Jeeper
 
Join Date: Aug 2010
Posts: 33
I've been hearing that. How do I hook that up? Use one of those splicing things that tap in, connect that positive, and run a ground? And where in the positive wire do I splice?
20PSI is offline   Quote Quick Reply
Old 09-17-2010, 11:34 PM   #4
Jeeper
 
brent in az's Avatar
 
Join Date: Feb 2010
Location: Verde Valley, AZ
Posts: 421
Same here. Great at wrenchin, crappy at electrical.
I spliced a ballast into the ig sys of an older jeep but your prob sounds eerily familiar. Does your rig have an ignition module? That would be my first guess. It's a reach since this is a mid-80's relic.
brent in az is offline   Quote Quick Reply
Old 09-18-2010, 05:49 PM   #5
Jeeper
 
Join Date: Aug 2010
Posts: 33
brent- yeah, it's got a module. I replaced it. $220 later... -_-
20PSI is offline   Quote Quick Reply
Old 09-18-2010, 07:29 PM   #6
Jeeper
 
brent in az's Avatar
 
Join Date: Feb 2010
Location: Verde Valley, AZ
Posts: 421
If you replaced it my guess is something, somewhere is not grounded. I'd check everything random from the starter ground to tail lights ground. Sometimes it's a miracle what a visual inspection will do. I hope you get that lucky.
brent in az is offline   Quote Quick Reply
Old 09-20-2010, 08:22 PM   #7
Jeeper
 
Join Date: Aug 2010
Posts: 33
Well what doesn't make sence to me is how it started, and then all of a sudden wouldn't. Like I moved it in my driveway to vacum it out of boredom the first time, and then when I went to move it again once I was done, no spark. Then after getting the module I didn't need, and a coil, it started right up. but then once I shut it down to put something back together, it mwouldn't start again.

20PSI is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lift using zj v8 coils/ crown victoria coils MoA TJ General Discussion Forum 37 04-05-2011 10:27 PM
Ignition / ignition switch farthammer TJ General Discussion Forum 4 02-27-2011 12:38 PM
Ignition Coil Blowing Out andiesel YJ Tech Forum 16 09-15-2010 01:17 PM
Blowing ignition modules Grandpa Jeeper YJ Tech Forum 12 09-04-2007 11:48 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:43 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC