Cam Position Sensor - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-10-2010, 09:50 AM   #1
Newb
 
Join Date: Jul 2010
Location: Wyoming Michigan
Posts: 13
Cam Position Sensor

I know this has popped up in the forum many times, but I wanted to post my findings/actions.

Whenever it got cold/wet out the CEL would come on like normal, you could hear the fuel pump prime, all the normal things. But, when you turned the key, it would turn over, and over, and not fire. I would check the codes, and get the Distributor Sync Pickup error. Eventually, it would fire up and be ok for a period of time (next cold spell/rain shower)

Once started the jeep ran fine....

Through research here and some very understanding mechanic friends, it was determined that the Cam Postion Sensor was flaking out. I checked with my local parts house (I have a very good friend there, and if your in the GR Michigan area, go see him!!! Message me for his contact information)
The CPS was only a few dollars less than a reman'd distributor. The CPS, and the piece that it reads from underneath are brand new.

Short story, long, I replaced the the Dist with the reman'd one, plug wires, rotor, and cap (I mean, heck I'm there, right?)

The Heep fired right up, and is actually running much better!

I will, however, claim this as a victory only after our first really cold spell, which is coming like a freight train...... It is Michigan, you know!

Now on to other necessary Jeep related things!

TBell is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam Position Sensor tapping ttuley TJ Tech Forum 25 04-23-2015 07:23 AM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
throttle position sensor voltage problem scout800 YJ Tech Forum 0 07-21-2010 09:09 PM
Cps ????? tequila1pint TJ Tech Forum 9 04-06-2010 12:20 PM
'97 or newer TJ 4.0L Crankshaft Position Sensor (good for a spare too) $50 Jerry Bransford Classifieds Archive 1 02-04-2007 10:31 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:31 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC