Carb help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-30-2012, 11:43 PM   #1
Newb
 
Join Date: Aug 2012
Posts: 5
Carb help

Put a weber on my jeep having problems getting it run. Will only start if I cover the top with my hand.

Travis82 is offline   Quote
Old 08-30-2012, 11:47 PM   #2
Jeeper
 
MkUltraOps's Avatar
 
Join Date: Aug 2012
Location: Snohomish, wa
Posts: 396
Quote:
Originally Posted by Travis82
Put a weber on my jeep having problems getting it run. Will only start if I cover the top with my hand.
Keep your hand on it...

__________________
Its a Jeep thing...
MkUltraOps is offline   Quote
Old 08-30-2012, 11:51 PM   #3
Jeeper
 
MkUltraOps's Avatar
 
Join Date: Aug 2012
Location: Snohomish, wa
Posts: 396
Idk maybe the Carb is too lean...could be a number of things
__________________
Its a Jeep thing...
MkUltraOps is offline   Quote
Old 08-31-2012, 03:31 AM   #4
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,711
Is the choke shut?????
__________________
"For Gawd's sake, put a RELAY in there or you could burn the whole damn Jeep to the ground" ...this quote brought to you by people who do not understand the law.....Kirchoff's, Ohm's, or Faraday's.
Violation of KISS shall always ring false in TRUE engineering. - ME___
Had 75CJ5, 89YJ, 93YJ. Have 82CJ7 & 95YJ____Not one burnt yet due to lack of relays.
bc3_Jeep is offline   Quote
Old 08-31-2012, 05:27 AM   #5
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,926
sounds like a vaccum leak to me..either a port needs plugging or a gasket not sealing..hold your hand over it so that it will run while shooting carb cleaner on different areas of the carb and see if it changes..that won't always find the leak but many times it will
harleydragon is offline   Quote
Old 08-31-2012, 05:48 AM   #6
Deaky

WF Supporting Member
 
Fweaky's Avatar
 
Join Date: Aug 2009
Location: Central Virginia
Posts: 2,216
Images: 18
X2 on the vaccum leak
__________________
Nothing is foolproof to a sufficiently talented fool.
Fweaky is offline   Quote
Old 08-31-2012, 09:26 AM   #7
Jeeper
 
MkUltraOps's Avatar
 
Join Date: Aug 2012
Location: Snohomish, wa
Posts: 396
What you really should do is go get a 4.0 EFI
__________________
Its a Jeep thing...
MkUltraOps is offline   Quote
Old 09-01-2012, 12:16 PM   #8
Jeeper
 
87yjman's Avatar
 
Join Date: Jun 2012
Posts: 127
cant beat a carb and msd igntion! simple enough. but yea huge vacuum leak will make it run with your hand on carb. sucking too much air from elsewhere
87yjman is offline   Quote
Old 09-02-2012, 04:23 PM   #9
Newb
 
Join Date: Aug 2012
Posts: 5
Quote:
Originally Posted by harleydragon
sounds like a vaccum leak to me..either a port needs plugging or a gasket not sealing..hold your hand over it so that it will run while shooting carb cleaner on different areas of the carb and see if it changes..that won't always find the leak but many times it will
It will die with my hand on the carb only runs for about ten sec.
Travis82 is offline   Quote
Old 09-03-2012, 07:34 PM   #10
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,926
sounds like a very bad vacuum leak..with your hand over the carb try giving it throttle and see if you can keep it running..a gas engine needs a mixture of gas and air to run..if the mixture is perfect then it runs great..if the mixture is off it may run but run rough..when you have a vaccum leak then the engine is pulling in more air and on top of that vaccum leaks happen below the carb so that the air that the engine is pulling in is not being pulled through the carb to pull gas in with it..when you pump the throttle it shoots gas through the accelerator pump so this will basically be artificial respiration while you try to find the vaccum leak..if this does not help you find the problem then visually inspect any vaccum lines for problems..check for any open ports on the carb or intake..if you don't find any problems there I would probably put a kit in the carb and replace the base gasket...if the carb you installed is new then make sure you used the correct base gasket and the bolts are tight

harleydragon is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:21 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC