Charging System Question 93 YJ 2.5L - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-17-2013, 06:47 AM   #1
Jeeper
 
truittsosebee's Avatar
 
Join Date: Sep 2013
Location: Canton, GA
Posts: 54
Charging System Question 93 YJ 2.5L

I just got a 93 YJ with the 2.5L a couple weeks ago. It's my first jeep and I'm loving it! The charging system has been acting up for the last 3 or 4 days. When I crank it first thing in the morning the volt gauge on the dash goes to 14V and stays there for my 20 minute ride to work. However, if I stop on the way and re-crank it, the volt meter drops to 9-10 volts and the check engine light comes on. When I crank it at lunch, still 10 volts. Going home still 10 volts. The next morning, the engine cranks fine and the volt meter goes back to 14 volts for the ride to work. Any ideas? All of my connections look very clean. I'm going to check things out with a meter tonight, just don't really know what to look for. Thanks for any help or advice.

__________________
1993 YJ 2.5L 5 speed
4" RC Suspension Lift
BF Goodrich AT 32x11.50s on factory TJ Wheels
TeraFlex Shackles
2" Wheel Spacers
truittsosebee is offline   Quote Quick Reply
Old 09-17-2013, 08:48 AM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,280
Yeah it is probably the gauge. Are all the others stable and read correct? Typical wrangler issue. You may have to pull instrument cluster and clean the cooper film everything is connected to on back. 6 screws one plug whole thing comes out. Tear down on a table and clean the contacts for all. Takes about an hour.

After that check you amp gauge and see how it reads.

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 09-17-2013, 07:37 PM   #3
Jeeper
 
truittsosebee's Avatar
 
Join Date: Sep 2013
Location: Canton, GA
Posts: 54
Checked the alternator with my meter tonight and was only getting 12.3V at the wire coming off the back of the alternator. Went and had it tested and autozone tested the alternator as bad too, so I bought a new one. I'll put it on in the morning and hopefully my issue will be resolved.
__________________
1993 YJ 2.5L 5 speed
4" RC Suspension Lift
BF Goodrich AT 32x11.50s on factory TJ Wheels
TeraFlex Shackles
2" Wheel Spacers
truittsosebee is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:07 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC