Check Engine Light('95) - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-17-2008, 11:05 AM   #1
Jeeper
 
Join Date: Oct 2007
Location: NC
Posts: 78
Check Engine Light('95)

I was driving home from work last night and my check engine light came on. I know that it ain't a big deal so I drove on home. Got home and pulled the codes out. I got a 12, 33, and 21.

33 is AC Clutch Relay, which doesn't make sense, 'cause I don't have AC.

21 is O2 Sensor or Circuit. I'm pretty sure that this is the problem. I've noticed that my gas mileage has dropped and sometimes the exhaust smells like it's running rich. Plus, the Jeep's got 77k on it.

Here's the strange thing, I checked my repair manual, and there ain't a code 12. The TJ has a code 12, but the YJ doesn't. I'm clueless.

Any ideas about any of these?

One last note, since I heard the engine running, I didn't pop the hood and see if the engine was still there. Should I have done this? My mom said she thought she heard something running up the driveway.

Unheroic Hero is offline   Quote Quick Reply
Old 03-17-2008, 12:12 PM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
i think it puts that out at the beginning and end of diagnostic cycle. pretty sure you just disregard it if you don't get a code from manual.

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 03-17-2008, 01:41 PM   #3
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
Smile

Quote:
Originally Posted by jpdocdave View Post
i think it puts that out at the beginning and end of diagnostic cycle. pretty sure you just disregard it if you don't get a code from manual.
this is correct the "12" code is the comp. "testing" the diagnostic cuircit if you get this "code" it means your system is working properly
spazinweasel is offline   Quote Quick Reply
Old 03-17-2008, 10:31 PM   #4
Jeeper
 
jeeper95yj's Avatar
 
Join Date: Jun 2007
Location: Parsippany, NJ
Posts: 150
replace the 02 sensor first, this can thrwo everything off. After, disconnect the battery for about 20 min. then reconnect and see if the light is still on. If it is, run the diagnostict again. But I think the 02 sensor should do it. It throws a lot of things off. THis is from experience and what a mechanic buddy had me do.
__________________
95 Yj I-6 Newly Rebuilt
Dana 35 Rear Newly Rebuilt
4inch Skyjacker Suspension Lift
2inch Shackle Lift
Skyjacker Nitro 8000 Shocks
Flowmaster 50 Series Delta Flow
33 X 12.50 X 15 Goodyear Wrangler MTR's
jeeper95yj is offline   Quote Quick Reply
Old 03-17-2008, 10:48 PM   #5
Jeeper
 
Join Date: Oct 2007
Location: NC
Posts: 78
One more thing, the light doesn't stay on. I drove the Jeep to work and it didn't come on. Drove it home and the light came on at the same place as it did last night.
Unheroic Hero is offline   Quote Quick Reply
Old 03-17-2008, 11:05 PM   #6
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
that usually means the jeep has to warm up or it is an intermitant prob.
spazinweasel is offline   Quote Quick Reply
Old 03-18-2008, 09:01 AM   #7
Jeeper
 
Join Date: Mar 2008
Location: Southcentral PA
Posts: 23
Double check all your connections in the wiring harness. You may have a loose connection somewhere that keeps tripping the codes in the computer. I had that problem and it drove me nuts.
jake4r is offline   Quote Quick Reply
Old 03-19-2008, 11:51 PM   #8
Jeeper
 
Join Date: Oct 2007
Location: NC
Posts: 78
I swung by and saw my mechanic yesterday just to get another opinion. He pulled the codes and then cleared them. The check engine light ain't came on since, but if it does, I'll replace the O2 sensor. As for the AC code, he said that water got into the AC plug. The AC code came back, but I'm not too worried about that.

Unheroic Hero is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 05:47 PM
check engine light gamecock22 TJ General Discussion Forum 21 03-05-2012 03:15 PM
check engine light, tied to 4WD use? frankfletez YJ Tech Forum 2 08-09-2008 01:54 PM
Idling strange = check engine light? Rubigoddess TJ Tech Forum 6 03-01-2008 01:38 PM
Fuel level sensor / check engine MouthfulOfGrass TJ Tech Forum 1 02-09-2007 05:41 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC