Clutch Bad? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-25-2011, 03:40 PM   #1
Newb
 
Join Date: May 2011
Posts: 2
Clutch Bad?

I need to figure out if my clutch is bad on my 94 yj 4.0 175k miles. I just bought it about a month ago and it seemed to run ok. After i started driving it daily, I found that every time i shifted and took my foot off the clutch it felt like the clutch was still partially engaged: I had no accelerating power but the rpms would still rise slightly even though I wasnt actually accelerating. I started to smell a wierd burning smell today so i pulled over to check under the hood. But when I went back to move the vehicle, it wouldnt move in first gear..... i can take my foot off the clutch in every gear and the car does not move or stall (and no the ebrake is not on). Obviously there is a problem but i dont know what it is. It is a hydraulic system so it could be the master, slave, etc, right?? I have always thought that if a clutch was bad it wouldnt go into gear or it would grind like crazy. The resistance on the clutch is no different than when it worked properly. Also, it seemed pretty hot under the car.

If anyone has an opinion on my issue I would appreciate the feedback. Thanks

palderman83 is offline   Quote
Old 05-25-2011, 04:00 PM   #2
Jeeper
 
C.L.'s Avatar
 
Join Date: Mar 2011
Location: North NJ
Posts: 2,203
Quote:
Originally Posted by palderman83 View Post
I need to figure out if my clutch is bad on my 94 yj 4.0 175k miles. I just bought it about a month ago and it seemed to run ok. After i started driving it daily, I found that every time i shifted and took my foot off the clutch it felt like the clutch was still partially engaged: I had no accelerating power but the rpms would still rise slightly even though I wasnt actually accelerating. I started to smell a wierd burning smell today so i pulled over to check under the hood. But when I went back to move the vehicle, it wouldnt move in first gear..... i can take my foot off the clutch in every gear and the car does not move or stall (and no the ebrake is not on). Obviously there is a problem but i dont know what it is. It is a hydraulic system so it could be the master, slave, etc, right?? I have always thought that if a clutch was bad it wouldnt go into gear or it would grind like crazy. The resistance on the clutch is no different than when it worked properly. Also, it seemed pretty hot under the car.

If anyone has an opinion on my issue I would appreciate the feedback. Thanks
Bad pressure plate, or friction surface is completely burned off the clutch plate. The grinding or not going into gear would be if the clutch failed closed; it sounds like yours has failed open.
C.L. is offline   Quote
Reply

Tags
6 cylinder , clutch , gear , overheating , transmission

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 7 08-30-2014 06:36 AM
Clutch issues 2008 todd451 JK General Discussion Forum 8 07-30-2013 03:46 PM
Engine & Clutch Issues - What Would You Do? stjbg01 TJ General Discussion Forum 3 05-13-2011 07:30 AM
Cherokee Master Clutch Kits - Free Shipping! AOR Vendor Spotlight! Great Deals for Members. 0 04-25-2011 10:35 AM
Please Help! Tranny or Clutch Problem?? stjbg01 TJ General Discussion Forum 14 04-11-2011 01:29 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:52 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC