Clutch problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-09-2008, 09:06 PM   #1
Newb
 
locorogue's Avatar
 
Join Date: Jun 2008
Location: well
Posts: 2
Clutch problem

Me noob, so be gentle. And also would like to appologise if this problem has been answered in a previous thread

I just bought a '90 YJ about a month ago. Approx 2 weeks ago, i noticed a leak under the jeep, and shifting started to be difficult. I checked the clutch fluid level, it was low. I filled to max. Shifting returned to norm. Approx 1 week ago, same scenario as 2 weeks ago. Only this time after I filling to max, clutch would not engage at all. I followed the clutch line to the clutch housing. I noticed the rubber insulator was worn, about 1/4 was gone. I pulled the rest out and noticed that indeed a 1/4 was missing, and obviously there was no seal.

I guess i'm hoping that I can fix this myself. I know that replacing the rubber seal is obvious, has anyone been able to just replace the rubber seal and the clutch return to norm? To replace the rubber seal, can I remove the clutch bleed line from the clutch housing, or does the housing need to come off? Any help would be incredibly helpful, thanks.

1990 Wrangler YJ
2.5L
5 speed

locorogue is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Problem with clutch? Paul.mea TJ Tech Forum 9 01-16-2009 07:25 PM
1990 need help transmission or clutch problem ?? sxmjeepdriver YJ Tech Forum 13 11-02-2008 11:01 AM
clutch and shifting problem upinar TJ Tech Forum 1 05-11-2008 08:12 PM
Clutch Problem again acopsy88 TJ Tech Forum 4 11-09-2007 10:27 AM



» Featured Product

All times are GMT -5. The time now is 08:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC