Clutch problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-29-2008, 11:16 PM   #1
Newb
 
Join Date: Sep 2008
Posts: 4
Angry Clutch problem

My problem is when my jeep gets hot, it seems to get harder and harder to shift. Once I turn off the jeep and let it cool, the problem goes away until it gets hot again. I have just replaced my entire clutch system. (Slave, master and internal clutch parts in the transmission. I need help.

ridge24shark is offline   Quote Quick Reply
Old 09-30-2008, 04:26 PM   #2
Jeeper
 
Join Date: Jul 2008
Posts: 38
Probably not the problem, but how's your clutch fluid level?

__________________
93' YJ, 2.5l with Ax-5, NP-231, Herc'd Tub, 33x12.50x15 BFG AT/KO, 15x10 Pacer Wheels, Custom rear bumper/ tire carrier, Cobra Ultra 19 CB, Pro-crap shocks, saggy stock springs, yada yada yads
BamianYJ is offline   Quote Quick Reply
Old 09-30-2008, 06:04 PM   #3
Newb
 
Join Date: Sep 2008
Posts: 4
Clutch fluid level is full.
ridge24shark is offline   Quote Quick Reply
Old 09-30-2008, 08:54 PM   #4
Jeeper
 
Join Date: Sep 2008
Location: Terlingua
Posts: 265
Did you change the pilot bearing when you did the clutch?
Lancem is offline   Quote Quick Reply
Old 11-27-2008, 09:22 AM   #5
Newb
 
Join Date: Oct 2008
Posts: 2
I have the same issue! I just changed my slave cylinder pressure plate and clutch. And it shifts excellently when cold but after a long time driviing it is difficult to shift and reverse tends to grind.
boeing747arowair is offline   Quote Quick Reply
Old 11-30-2008, 12:32 PM   #6
Jeeper
 
spazinweasel's Avatar
 
Join Date: Feb 2008
Location: elizabeth co
Posts: 270
sounds like possibly bad slaves clutch companys still havent figured out how to build these without the leaks. if it gets a little better with pumping i would bet it is this if not it is probably the pressure plate is old and worn. good luck all

__________________
89 yj 4.0 conversion 89 grand waggy tbi
spazinweasel is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Problem with clutch? Paul.mea TJ Tech Forum 9 01-16-2009 07:25 PM
1990 need help transmission or clutch problem ?? sxmjeepdriver YJ Tech Forum 13 11-02-2008 11:01 AM
Clutch problem locorogue YJ Tech Forum 0 07-09-2008 09:06 PM
clutch and shifting problem upinar TJ Tech Forum 1 05-11-2008 08:12 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC