clutch wont return on 92 yj - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-18-2013, 11:03 PM   #1
Jeeper
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 176
clutch wont return on 92 yj

my clutch pedal will not return the clutch does still work but pedal stays almost completely on the floor it started the other day on the way home from the beach the pedal would not go in all the way if i let off the pedal and pushed it again it would go in all the way this happened a few times then it made a popping noise when i pushed the clutch i stopped at home for money for car wash when i got back in my pedal wouldn't return i would appreciate any advice i went to a local shop and they said they could replace everything for 1500 that seems a bit much but if i pay to have the transmission pulled i should probably replace everything anyway sense it is internal slave being it is a 92 yj thank you in advance

tylerf83 is offline   Quote Quick Reply
Old 02-19-2013, 08:14 AM   #2
Jeeper
 
RandomYJguy's Avatar
 
Join Date: Nov 2012
Location: LaCrosse WI
Posts: 263
Check and see if you have any fluids in the resevoir (resevoir right next to the brake booster on the firewall) I had a problem similar, and i just had to put fluid in and then bleed the line...

RandomYJguy is offline   Quote Quick Reply
Old 02-19-2013, 08:31 AM   #3
Jeeper
 
The Silver Gorilla's Avatar
 
Join Date: Jan 2013
Location: Tampa
Posts: 641
Had a similar problem, try flicking the clutch with your foot a few times, and check your fluids. My clutch fluid was a little low so i filled it and it hasnt been a big problem since, if it does get stuck i just flick the clutch and i can go into gear.
The Silver Gorilla is offline   Quote Quick Reply
Old 02-19-2013, 09:07 AM   #4
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,353
Crawl under dash and see if the return spring is still attached to the peddle assy.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 02-19-2013, 11:41 AM   #5
Jeeper
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 176
ok thanks for the reply's my fluid was not low already checked the day it happened i cycled the clutch even drove it a little i have read about the spring but does a 92 yj have one all i could find was literature about cj and some early yj but couldn't find it in the parts diagram
tylerf83 is offline   Quote Quick Reply
Old 02-19-2013, 12:09 PM   #6
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,353
Honestly don't know about 92 but I have one on an 88.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 02-19-2013, 03:37 PM   #7
Jeeper
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 176
should have said this earlier but didnt when i checked the fluid it seemed to have to much some came out when i opened it is there a spring in the master to push the pedal back the pedal is very sloppy if you pull it up it just falls down and also the slave leaks a little here and there
tylerf83 is offline   Quote Quick Reply
Old 02-19-2013, 04:28 PM   #8
Jeeper
 
heh1994's Avatar
 
Join Date: Oct 2012
Posts: 75
When mine did that it was a bad slave cyl...did you try bleeding it yet?
heh1994 is offline   Quote Quick Reply
Old 02-19-2013, 05:34 PM   #9
Jeeper
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 176
no the clutch only has about a inch of travel is that enough to bleed it
tylerf83 is offline   Quote Quick Reply
Old 02-19-2013, 08:13 PM   #10
Jeeper
 
Join Date: Jan 2013
Location: New Jersey
Posts: 28
I have a 92 and I don't see a spring on the clutch pedal. My slave leaks a bit and I just fill the master every week and no problem (doing that for 5 yrs now). If you weren't low on fluid I wonder if your master is shot?

sem7 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 10:17 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC