cold starting problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-03-2007, 10:30 AM   #1
Newb
 
Join Date: Nov 2007
Posts: 4
cold starting problem

I have a 1995 Rio Grande that is really hard starting cold, turns over alot then will fire and sputter and then runs fine, I have tried the cap, rotor wires and plugs, any idea's. It has a 2.5 liter with a stick, 80k miles, thanks jim

grogan14 is offline   Quote Quick Reply
Old 11-03-2007, 10:48 AM   #2
Jeeper
 
drummerwookie's Avatar
 
Join Date: Oct 2005
Location: Piqua Ohio
Posts: 342
Send a message via AIM to drummerwookie Send a message via Yahoo to drummerwookie
just a guess, but check the fuel filter, make sure its free of anything that could cause it to starve for gas in the morning. maybe even check the air filter for the hell of it and see how thats doing. the only other thing i could think of is the distrubutor itself
__________________
current:
1995 YJ Rio Grande, 1993 XJ sport trail rig

gone but never forgotten:
2006 rubicon, 1995 YJ, 1998 ZJ, 1993 YJ 4.0
2004 WJ Limited
drummerwookie is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
starting problem ty95yj YJ Tech Forum 6 07-29-2008 02:21 AM
Still, cold starting problem grogan14 YJ Tech Forum 0 11-05-2007 09:34 AM
Starting problem, tryingto troubleshoot NJJeeper YJ Tech Forum 2 08-20-2007 06:17 PM
problem starting.. RustyNBeatin2000 TJ Tech Forum 5 06-30-2007 01:02 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC