defroster isnt working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-15-2010, 05:50 PM   #1
Jeeper
 
89JEEPYJ's Avatar
 
Join Date: Oct 2010
Posts: 967
defroster isnt working

i have a 89 yj and i put the hard top and the defroster isnt working. it has power to the window and it has a ground to the window, what else could be wrong that it wouldnt work. the wires going across appear to be good, i dont c any reason why it isnt working

89JEEPYJ is offline   Quote
Old 10-18-2010, 01:54 PM   #2
Jeeper
 
89JEEPYJ's Avatar
 
Join Date: Oct 2010
Posts: 967
anyone anything at all?
89JEEPYJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard top wiring kit - Rear defroster always on JCS05Rubi TJ General Discussion Forum 5 09-16-2014 07:29 AM
2007 Sahara Radio not working PDB Communications and Electronics 3 09-08-2010 06:56 PM
Fixed Defroster for .50 cents jamesdeanblvd TJ General Discussion Forum 3 12-14-2009 01:43 PM
Rear Window Defroster not working bennettsr4 TJ Tech Forum 1 03-14-2009 06:16 PM
Rear Defroster Not Working..?? draft51 TJ Tech Forum 2 02-24-2009 09:27 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:45 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC