electrical issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-28-2009, 07:00 PM   #1
Newb
 
Join Date: Jan 2009
Posts: 9
electrical issue

trying to install new radio bought wire harness for my model plugged in went to start it up and jeep went completely dead. No lights no anything. Battery is good. Checked all fuses in power distribution box thay all looked good. What could it be?

ironman59 is offline   Quote Quick Reply
Old 01-28-2009, 08:32 PM   #2
Jeeper
 
Fire Hart's Avatar
 
Join Date: Jul 2008
Location: Wichita KS
Posts: 149
did you cut the ingnition box out under the steering wheel???

__________________
95' YJ, 4 hamsters under the hood, 4 inch RC lift, 2 inch body lift, 4.11 gears, 33 inch M/T Tires, rock crawler rims, full Dynomax exhaust, cold air intake, Hand throttle, CB, and lots of mods in mind.
Fire Hart is offline   Quote Quick Reply
Old 01-28-2009, 10:24 PM   #3
Jeeper
 
aalmutawakil's Avatar
 
Join Date: Nov 2008
Location: VA
Posts: 240
are you saying that battery is good because you know it or because you tested it. check the wiring under the steering wheel as hart said. thats your best bet. its a mouse trap when it comes to wiring in jeeps.
__________________

__________
l__l__\____\
l/-\l-_l_/ --#llllll#-
\__/ - \____H ___H MUTAWAKIL
(o)__) (o)__)---o-)__) 4847444222
aalmutawakil is offline   Quote Quick Reply
Old 01-29-2009, 07:36 PM   #4
Newb
 
Join Date: Jan 2009
Posts: 9
Thanks it turns out the battery was good but the connection became week at terminal lug just happened at same time as installed radio.
ironman59 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 electrical issue? jyeast TJ General Discussion Forum 5 12-15-2011 06:52 PM
Electrical issue macleay YJ Tech Forum 1 02-09-2008 12:40 AM
Wierd electrical issue skrappi CJ Tech Forum 0 08-21-2007 03:49 PM
Weird electrical issue Geeps TJ Tech Forum 5 01-08-2007 01:49 PM
electrical issue khenderson TJ Tech Forum 2 09-15-2005 04:38 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC