Electrical Problem Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-28-2008, 10:27 AM   #1
Jeeper
 
Join Date: Mar 2008
Location: New Braunfels, Tx
Posts: 57
Electrical Problem Help

Alright guys, got a 88 YJ with a I6, manual tranny. Jeep has been running good. Woke up this morning, hopped in to bring my son to school and Nothing. It appears to be an electrical problem, but I don't know alot about electrical issues with a Jeep. I took out my meter and the battery has enough voltage, but I am guessing that this is probably some type of fuse problem. Nothing on the dash bumps either.

HELP

__________________
Let's Roll Boys!
popatop is offline   Quote Quick Reply
Old 09-04-2008, 08:29 PM   #2
Newb
 
88TNSahara's Avatar
 
Join Date: Sep 2008
Location: Chattanooga, TN
Posts: 8
Quote:
Originally Posted by popatop View Post
Alright guys, got a 88 YJ with a I6, manual tranny. Jeep has been running good. Woke up this morning, hopped in to bring my son to school and Nothing. It appears to be an electrical problem, but I don't know alot about electrical issues with a Jeep. I took out my meter and the battery has enough voltage, but I am guessing that this is probably some type of fuse problem. Nothing on the dash bumps either.

HELP
Battery voltage isn't what starts the motor... it's the amps.
Is nothing happening at all when you turn the key? Is the starter turning but the motor isn't? etc... kinda need more info to help out on this one.

__________________
1988 Sahara A/T
88TNSahara is offline   Quote Quick Reply
Old 09-07-2008, 02:53 PM   #3
Jeeper
 
Join Date: Mar 2008
Location: New Braunfels, Tx
Posts: 57
Was a loose wire connection to the battery on the positive side. That problem has been fixed
__________________
Let's Roll Boys!
popatop is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
2000 TJ Electrical Problem Dennis G TJ General Discussion Forum 14 03-01-2012 04:30 PM
electrical problem...help!!! evas98tj TJ Tech Forum 3 10-10-2008 11:18 PM
electrical problem??!! YJ93 YJ Tech Forum 5 12-18-2006 12:18 PM
electrical problem stu TJ Tech Forum 5 01-30-2006 01:37 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC