Engine acting up - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-14-2010, 06:51 AM   #1
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
Engine acting up

I have a '90 and the engine since I took offroad has been acting up. When driving it is fine, but, when wanting to brake for a light it keeps wanting to go. It has a "buck" to it. Could water of gotten into it? Also, while trying to get it started this morning it would idle at 1.5 and then shut off. I restarted it about 3 times before I was able to drive away. Any and all help is appreciated! Thanks!

monteYJ is offline   Quote Quick Reply
Old 05-14-2010, 07:05 AM   #2
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
Also it is non carb.

monteYJ is offline   Quote Quick Reply
Old 05-14-2010, 08:07 AM   #3
Jeeper
 
tlrrob1000's Avatar
 
Join Date: Jul 2009
Location: Pain is a gift...Fear is not an option!
Posts: 786
Images: 23
4 or 6 Cyl.? If it is a 6 is it a 4.2 or did you slap a 4.0 into it?
__________________
No Bad Days!
tlrrob1000 is offline   Quote Quick Reply
Old 05-14-2010, 08:30 AM   #4
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
make sure a plug wire or coil wire did not come loose first. Sometimes they'll pop right off the coil. They will still spark accross the gap but it would run very irratic.

Also check your battery cables at both ends and ensure they are clean and tight. The throttle body is really dependable upon a good battery connection.



Give us some more details of the trip. Did you get 'er all wet? Fall off a cliff? Anything get jarred or slammed? Did you rev it to 9,000 RPMS in nuetral then slam it into drive? hehe... just let us know if anything strange occured that could have messed something up.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 05-14-2010, 01:33 PM   #5
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
She just got all wet and dirty. It is a 6cyl. I just did some light offroading with puddles about 4in deep. It was rather dry out. The issue is no longer rearing its ugly head lol.
monteYJ is offline   Quote Quick Reply
Old 05-14-2010, 01:45 PM   #6
Jeeper
 
toshpate's Avatar
 
Join Date: Feb 2010
Location: Oklahoma
Posts: 19,285
Images: 4
Send a message via AIM to toshpate Send a message via Yahoo to toshpate Send a message via Skype™ to toshpate
mine does that all the time..that's not normal behavior for an old jeep heh hehe he hee???
__________________

GOOOOOOOOOO POKES!!!!!!
toshpate is offline   Quote Quick Reply
Old 05-14-2010, 01:46 PM   #7
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
I have the same problem and would love some insight from someone that may know what is up with this.

I drove 6 hours yesterday through rain and storms all day, seriously tons of water, rivers flooded and everything...

Not one problem with the jeep at all. Took in the cool air and loved every minute of the ride.

Now, on the other hand, three days ago I splash through a puddle on my road and she starts spitting and sputtering into the driveway. Starts back up after lunch, sputters when backing out, cuts out on me for a second or two then picked back up for the ride.

Its wierd that I can drive in heavy rains without an issue, but I splash in a little puddle and she cuts out on me.

Im wondering if water puddles up on the battery and shorts it for a few??? I also thought about spraying silicon on all my connections under the hood.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 05-14-2010, 02:02 PM   #8
Jeeper
 
Join Date: Oct 2009
Location: New Jersey
Posts: 71
Never said it wasn't Toshpate. Just seeing what it could be.
monteYJ is offline   Quote Quick Reply
Old 05-14-2010, 02:04 PM   #9
Jeeper
 
toshpate's Avatar
 
Join Date: Feb 2010
Location: Oklahoma
Posts: 19,285
Images: 4
Send a message via AIM to toshpate Send a message via Yahoo to toshpate Send a message via Skype™ to toshpate
mine got a little better after we rewired my ignition coil and starter and battery tho. I still think I need new distributer cap and plugs and wires..will get there eventually

__________________

GOOOOOOOOOO POKES!!!!!!
toshpate is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seafoam? bato TJ Tech Forum 81 03-17-2014 01:37 PM
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
2.5 engine replacement now no spark or check engine light tdfeickert YJ Tech Forum 2 02-23-2012 10:53 PM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-07-2009 11:14 PM
Spedo dies and the engine dies when I brake jbhouse2k TJ Tech Forum 4 03-06-2007 07:17 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:23 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC