Engine cuts out - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-23-2010, 10:52 PM   #1
Newb
 
Join Date: Jun 2010
Posts: 2
Engine cuts out

Howdy:

My '89 wranglers engine shut off on me three times this mornining on the way to work and twice on the way home. The first Shut-off occured shortly after start up, the engine was warm but not hot. Each time the engine re-started with little trouble.

When it shuts off, it does not cough or sputter, it simply dies. Seems like an electrical problem.

6 cylinder, 5 speed - 140,000 miles. Any ideas?

MSL

survey0r1 is offline   Quote Quick Reply
Old 06-26-2010, 03:17 PM   #2
Newb
 
Join Date: Jun 2010
Posts: 2
Electrical problem solved

Got the Jeep running - The ignition control module (conveniently located under the radiator overflow tank) had gone bad. Replaced the unit along with the coil and got my strong spark back and the engine is now running.

survey0r1 is offline   Quote Quick Reply
Old 07-02-2010, 01:25 PM   #3
Jeeper
 
britcay's Avatar
 
Join Date: Sep 2009
Location: Grand Cayman, Cayman Islands
Posts: 26
Quote:
Originally Posted by survey0r1 View Post
Got the Jeep running - The ignition control module (conveniently located under the radiator overflow tank) had gone bad. Replaced the unit along with the coil and got my strong spark back and the engine is now running.
Clearly our YJ's were seperated at birth - I just did *exactly* the same thing on my '90 and it's pulling like a train now!

Why on earth they chose to fit it where they do is beyond me. Maybe it shields it from the worst of the weather?

Took me longer to find the little rascal than it did to go buy another and fit!
britcay is offline   Quote Quick Reply
Old 07-13-2010, 09:17 PM   #4
Jeeper
 
Join Date: Aug 2009
Posts: 68
survey0r1 ...what do you think? Is the same issue?
It started a few months ago where I was driving down the road and was trying to beat a yellow light, so I cut the turn a little hard, and the jeep shut down completey. I put in neutral and started no problem, I thought it was a fluke, until I had to go to Lowes the next week, and the same thing happened. Then it started happening on my way into work. I find that mostly when I make a left coming from a decent speed say 30 mph or more thats when it happens. So its a little weird to be honest since it jas only happened during left turns. Why does the jeep cut out (shut down) when I make hard lefts. It is getting a little dangerous because a few times I was attempingt to hang a left and it cut out, and had to quick put it in neutral and restart (which always starts with no problem)
I have a 97 sport automatic

Electrical or fuel pump?
imowt is offline   Quote Quick Reply
Reply

Tags
electrical problem

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seafoam? bato TJ Tech Forum 81 03-17-2014 01:37 PM
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
2.5 engine replacement now no spark or check engine light tdfeickert YJ Tech Forum 2 02-23-2012 10:53 PM
Engine Replacement Advice/Suggestions? Sledge General Jeep Discussion 1 05-17-2010 06:46 PM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-07-2009 11:14 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC