engine doesnt match "all original" jeep? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-13-2012, 10:45 PM   #1
Jeeper
 
Join Date: May 2012
Posts: 20
engine doesnt match "all original" jeep?

I started doing a valve cover gasket replacement today and the gasket for the engine that I should have doesnt fit.

the gasket I have looks like this

the gasket I need looks like this but wavy on both sides and with about 2 times the bolt holes. the only numbers I've been able to pull from the engine are 893003689 from the inside of the valve cover and a partial serial or casting number from the block near the distributor xxxx3cl23

I'm a bit worried about what I'm running now. I'm new to jeeps but it seems to me that I'm either running a newer wrangler engine, which would be fine; or a cherokee engine, not ok as it would mean I possibly also have a cherokee transmission... which I've heard many times are horrible.

I'm trying to post pics but all the links I put in from flikr dont work for some reason. if anyone can tell me how to post working links from flikr I have pics of the valve cover and the engine with the cover off.

EDIT: just go here for pics: http://www.flickr.com/photos/7850897...n/photostream/ and click newer pictures.

89YJ Convert is offline   Quote Quick Reply
Old 05-13-2012, 11:31 PM   #2
Jeeper
 
ItsSabby's Avatar
 
Join Date: Apr 2011
Location: Long Island, NY
Posts: 220
You certainly have a 4.2l engine which is what belongs in an 89 wrangler. There is a difference in the gaskets between an aluminum valve cover (which you have) and a plastic valve cover. Make sure you get the gasket to match your cover. I just did my valve cover gasket this weekend. Ill see if I can get you the part number I had.

ItsSabby is offline   Quote Quick Reply
Old 05-14-2012, 12:16 AM   #3
Jeeper
 
Join Date: May 2012
Posts: 20
Quote:
Originally Posted by ItsSabby View Post
You certainly have a 4.2l engine which is what belongs in an 89 wrangler. There is a difference in the gaskets between an aluminum valve cover (which you have) and a plastic valve cover. Make sure you get the gasket to match your cover. I just did my valve cover gasket this weekend. Ill see if I can get you the part number I had.
well I feel like a major noob missing the difference on the valve covers haha. I'm brand new to jeeps as of yesterday, thats my story and I'm stickin to it.
89YJ Convert is offline   Quote Quick Reply
Old 05-14-2012, 08:08 AM   #4
Jeeper
 
ItsSabby's Avatar
 
Join Date: Apr 2011
Location: Long Island, NY
Posts: 220
Lol it happens to everyone. Thevpart number to mine was Felpro VS 50022 C-1. That's a cork gasket for an aluminum valve cover. Should run you 5-10 bucks. Make sure not to overtighten the bolts when you put it back on. And start tightening from the middle and outwards in a circular pattern. By the time you get to the outside the middle bolts will have loosened so just go back around and make sure all is snug.
ItsSabby is offline   Quote Quick Reply
Old 05-14-2012, 08:13 AM   #5
Jeeper
 
ItsSabby's Avatar
 
Join Date: Apr 2011
Location: Long Island, NY
Posts: 220
Btw I too came from the Honda world. I still have my hatch also, but man I love this jeep. I have basically the same as you, 89 yj with the 4.2. I suggest doing the ignition upgrade as it makes a huge difference.
ItsSabby is offline   Quote Quick Reply
Old 05-14-2012, 09:48 AM   #6
Jeeper
 
Beachcruiser's Avatar
 
Join Date: Feb 2012
Location: Raleigh, NC
Posts: 429
x2 on the ignition upgrade. Especially if you swap out the slow factory advance springs.
Beachcruiser is offline   Quote Quick Reply
Old 05-14-2012, 10:49 AM   #7
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 2,790
yes you have a 4.2L. the valve cover that you have is aluminum, and the gasket that you have is for a plastic cover. i replaced mine just the other day, but i used a rubber gasket instead of the cork replacement. its a bit more money but the rubber will expand and contract with the heat changes, and the cork gasket will eventually leak.

i used a thin layer of black rtv gasket sealant on the cover to hold the gasket on the cover, and let it set up. then carefully set the cover onto the motor, and start all the bolts. then like said above, work from the center out to the front and back equally tightening the bolts.

it only takes about 15lbs of torque which i judge as snug with a 1/4" stubby ratchet. after you get the engine up to operating temp, go back over the bolts in the same tightening sequence.
0III0forlife is offline   Quote Quick Reply
Old 05-18-2012, 06:54 PM   #8
Jeeper
 
Join Date: May 2012
Posts: 20
@ItsSabby thanks for the parts number. replaced it yesterday. its amazing how much better an engine runs when its got an actual gasket in there instead of household silicone from PO haha. and I've been thinking of the ignition upgrade as well as possibly getting the mopar MPFI kit.
89YJ Convert is offline   Quote Quick Reply
Old 05-18-2012, 07:07 PM   #9
Newb
 
Join Date: May 2012
Posts: 9
The MPFI conversion is the way to go IMO. I bought myself an '87 Laredo a few weeks back and am fixin to install one in mine in another month or two. Better mileage, fewer start issues, fewer stall issues, just overall a better way to go.
fitpro79 is offline   Quote Quick Reply
Old 05-18-2012, 08:22 PM   #10
Jeeper
 
busemans's Avatar
 
Join Date: Dec 2010
Location: on the gulf of mexico
Posts: 1,352
and don't forget, you could easily have a cherokee engine or newer engine anyways. mine does, a 99 grand cherokee block under the 87 head. it still bolts to the old style trans.

the cherokee 4 speed is a great auto trans, i wish i had one in my jeep so i could have overdrive on the highway.

__________________
A lot of teenagers are people who express a burning desire to be different be dressing exactly alike.
Panties aren't my favorite, but they're right next to it...
No one is normal, there are just a lot of weird people with things in common.
busemans is offline   Quote Quick Reply
Reply

Tags
cherokee , engine , laredo , wrangler , wrong

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:46 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC